[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Redhat 8.0 and 2 GB RAM - maybe solved

At 07:43 PM 2/17/2003, Dimitri Deserranno wrote:

Thanks a lot for the info. I will certainly check this out.
I am currently running fine though with 1.5Gb in slots 1-3. No problems, at least so far (several hours). Any idea? Just luck maybe?
Actually, since your email, I put in the 4th dimm as well, okay so far. Difference is only that some dimms are now in other slots compared to when failure occured (normally in less than 10min).

suspect that this is just luck - the trick is to get long term stability and reliability,  if you are going to be doing long running computationally intense jobs

I just started memtest86-3.0 and I have a failing address already, on test#1. Any idea what this means? Does this have anything to do with comments from Paul?

see below

Anyways, I'll be calling Asus and Corsair tomorrow. Thanks a lot.


Athlon? MP processors with the A7M266-D: This dual-CPU ATX motherboard uses a standard power supply and supports up to 3.5GB of registered DDR memory (4 slots) or 2GB of un-buffered DDR memory (2 slots) to provide a scalable, high-performance platform for high-end desktops, workstations and entry-level servers...

Original system: (fully functional)
redhat 7.3
kernel 2.4.x smp (not sure - don't remember)
DDR Corsair memory CMX512-3200 (2 dimms)
ASUS A7M266-D (AMD MP recommended)

This shows that you had only the first 2 memory slots populated and it  worked with regular memory (not ECC registered), when you added memory in slots 3 & 4 it put additional stress on the MB chip set and it may or may not be able to meet proper timing for all memory. 

The quote from your manual simply reinforces this point.  The 2GB they mention assumes that you are using 1GB DDR DIMMs and they ONLY occupy the first 2 slots.  If you have all 4 slots filled with 1GB ECC registered (aka buffered) DIMM's then you will have a total useable capacity of 3.5GB (this reduced capacity is due to a peculiarity of the MPX chip set and how it handles PCI addressing/buffering).  When you use un-buffered (i.e., non-registered) DDR RAM in more than the first two slots, you will get errors.

FWIW, there is also an interaction with the PSU in the machine, so you ought to be sure you have a 400W+ PSU with good regulation, such as the Antec TruPower 430 or the PC Power and Cooling unit.  However, in this case your problem is clearly incompatible memory  type for the MB

The memtest86 errors reflect that the combination of the MB and the memory are not working well together.  Try the following to prove this to yourself.  Put your original 2 DIMM in slots 1 & 2 - run memtest86 through at least one full (all tests) iteration.  If the original DIMM are okay should run without error - save results in a file.  Now add 1 more DIMM in slot 3 - repeat, then add 4th DIMM in slot 4 - repeat.  You will see errors come up in the address space of the original good DIMM caused by timing and loading issues.  You may want to run several iterations of memtest86 to see the "random" nature of the errors.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]