[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

how source.tar.gz -> source.src.rpm -> binary.rpm



hi ...
i download the lasted version of php in tar.gz format ..
i unpack, ./configure with my options, make, make install..
it's all working ...
but my rpm database was "outdated" ..
now , when i try use apt-get to install any package, returns this error message:


Sorry, but the following packages have unmet dependencies:
  php-mysql: PreDepends: php (= 4.2.2-8.0.7) but 4.2.2-8.0.5 is installed

if remove php, it's will remove yours dependencies (mysql, pgsql, etc modules) ...

the way to correct this would be transform the tar.gz to src.rpm and build a binary .rpm to install with rpm -Uvh newphp.rpm ???

howto this ??

thankz for any help!!





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]