[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: network backups with tar - cannot generate passwordless SSH key

The problem why you can't reproduce my setup is because you use a 6.2 machine. I ran in the same kind of problems as you describe when I tried this a few days ago on a 7.0 machine. Has to do with the ssh configuration on the "older" redhat distros. They don't use the DSA keys by default. With other key-types ssh behaves differently.

I haven't checked it for you, but I think 7.2 should run as described.
I use this on 7.3 and 8.0 machines. There you definitly have no incompatibilities.

On the 7.0 machine I tried to upgrade the ssh to the latest version from the 7.0 update directory of RedHat to get it to work as I described. But I had to update several other packages as well. In my situation it was easier to upgrade to 8.0. If I am correct ssh starts using protocol 2 and dsa by default from the 3.x version on. So in theorie upgrading ssh to 3.x should make it work.

Regards, Koos.

At 15:27 21-02-2003 +0200, you wrote:

Unfortunately, still no joy. I assume that I am putzing up somewhere, so I
will give you a summarized log of exactly what I did on my servers.

The two test servers I am using:

'blackhawk' - Red Hat Linux 8 [ server that needs to be backed up]
'firewall' - Red Hat Linux 6.2 [ server that I am using for the 'backups'
(not really, just to test connection)]

When I do

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]