[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Oracle8i installation problems

     I had the same problem. Take a look to your alert_$ORACLE_SID.log in
$ORACLE_BASE/admin/$ORACLE_SID/bdump. I suppouse that you will see a
message like
'WARNING: EINVAL creating segment of size <Hexa number>".

     This is related to the SHMMAX kernel parameters. Do you have 128 Mb of
RAM? This problem only appeared me when installed ORacle 8i in my laptop,
that have 128MB, with servers this problem not exist
     I think that SHMMAX can be changed in /etc/sysctl.conf.
     Take a look to the shm values neede by ORacle 8i ( i don't remember it
now, but you will get it asking google )
     Edit /etc/sysctl.conf and search for kernel.shmmax entry. Comment (#)
this line and create another one with kernel.shmmax=value_needed.

     Another thing. Use dbassist to create a set of database creation
scripts and execute them manually. Dbassist in 8.1.7 is buggy. Don't forget
to apply patches after install the software and before database creation.
At least the first patch can be obtained here



David Ballester

Marko Asplund <aspa kronodoc fi>@redhat.com con fecha 26/02/2003 09:03:33

Por favor, responda a psyche-list redhat com

Enviado por:   psyche-list-admin redhat com

Destinatarios:     psyche-list redhat com

Asunto:   Oracle8i installation problems

i'm having problems installing Oracle8i (r3) on a Red Hat 8.0 machine.

the installation of the software itself goes fine but database creation
fails. i've tried creating the database both during and after installation
using the Oracle Database Configuration Assistant (dbassist) but it fails
with the following error message: 'ORA-12547: TNS: lost contact'. i've
also tried creating database creation scripts using dbassist and running
these scripts manually. the scripts use svrmgrl which fails to connect to
the database and prints the following error message: 'ORA-03113:
end-of-file on communication channel'.

any ideas on how to fix this problem? i have installed Oracle8i on a Red
Hat 7.3 machine where it runs fine.

best regards,

Psyche-list mailing list
Psyche-list redhat com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]