[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Postfix crashes (segfault) on RedHat 8.0. (cyrus-sasl-2.1.10 needs to be split)


It happened to med  when i tried to enable sasl2 for postfix on Redhat. I
needed to use saslauthd which comes with sasl2.

I found that Simon White had the same problem (URL):
And then solved it by installin his own sasl2 (URL):

I dug a little deeper into exactly what makes postfix/smtpd crash and burn
on RedHat like this and to get everything to work on the redhat sasl rpm's.

It seems that Redhat installs both sasl v1 and sasl v2, but calls the
package cyrus-sasl-2.1.10 ???

This is where the include files reside:
/usr/include/sasl.h    - Sasl v1 include file
/usr/include/sasl/sasl.h - Sasl v2 include file

So on redhat you have to compile postfix like this to get proper SASL2
% make makefiles CCARGS="-DUSE_SASL_AUTH -I/usr/include/sasl"

I initially forgot the -I/usr/include/sasl which meant that postfix was
compiled agaist sasl v1 include files and then linked against asl v2
libraries. That caused postfix/smtp to crash and burn.

Vietse Venemas patch helped me track down this:

if (SASL_SERVER_NEW("smtp", var_myhostname, *var_smtpd_sasl_realm ?
                        var_smtpd_sasl_realm : NO_AUTH_REALM,
                        server_address, client_address,
                        &state->sasl_conn) != SASL_OK)
        msg_fatal("SASL per-connection server initialization");

+   if (state->sasl_conn == 0)
+        msg_panic("sasl_server_new() succeeds and does not set

It would have been nicer if the sasl v1 support had been a separate package.
I hope RedHat fixes this in the next release.


Hans Eric

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]