[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ISDN Router - defaultroute



Hi,

I just installed RedHat 8 on new hardware and I want to configure Psyche to  
work with dial-on-demand-mode to connect to my isp via i4l.

My route -n after booting (without any isdn-device):
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
A script starts hisax, several isdnctrl-commands and finally, it starts:
/sbin/ifconfig ippp0 192.168.0.99 pointopoint 192.168.0.1
/sbin/ipppd

But now, I've got problems with routing. Before the first connection, I 
added to the script "route add default ippp0". route -n   shows:
192.168.0.1     0.0.0.0         255.255.255.255 UH    0      0        0 
ippp0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 
ippp0

In my ip-up, I put 
/sbin/route del default
/sbin/route add default gw $5 $1

After connect, route -n shows:
217.5.107.241   0.0.0.0         255.255.255.255 UH    0      0        0 
ippp0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         217.5.107.241   0.0.0.0         UG    0      0        0 
ippp0

In ip-down, i finaly put:
/sbin/route del default
/sbin/route add default ippp0

217.5.107.241   0.0.0.0         255.255.255.255 UH    0      0        0 
ippp0
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 
ippp0


It think, there works something wrong... on my old SuSE-Router, route -n 
shows after disconnect my dummy-ip:
192.168.0.1     0.0.0.0         255.255.255.255 UH    0      0        0 
ippp0
0.0.0.0         192.168.0.99    0.0.0.0         UG    0      0        0 
ippp0


Whats wrong? Can you please give me the right route (add and del)-Parameters
- before the first connection
- for ip-up      and finaly
- for ip-down ?

Thanks!
Henning





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]