[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Apache 1.3 or 2.0 for RH 8.0?



Hello,
I need some advice about Apache.  I want to learn it.  I have some RH8.0
machines with Apache 2.0.40 in them, but first experiments have not been
going well and most of the HOWTO and tutorial stuff is for 1.3.  
Also apache.org lists a number of problems between 2.40 and the current 
2.45 but I haven't found any upgrade RPMs.  I was going to uninstall 2.0
and install 1.3 but there are a bunch of depends on the installed 2.0,
including 

[root www sysconfig]# rpm -e httpd
error: Failed dependencies:
        httpd-mmn = 20020628 is needed by (installed) mod_perl-1.99_05-3
        httpd-mmn = 20020628 is needed by (installed)
mod_python-3.0.0-10
        httpd-mmn = 20020628 is needed by (installed) mod_ssl-2.0.40-8
        httpd-mmn = 20020628 is needed by (installed) php-4.2.2-8.0.5
        libapr.so.0 is needed by (installed) mod_perl-1.99_05-3
        libaprutil.so.0 is needed by (installed) mod_perl-1.99_05-3
        httpd >= 2.0.40 is needed by (installed) mod_perl-1.99_05-3
        httpd >= 2.0.40 is needed by (installed) mod_python-3.0.0-10
        httpd is needed by (installed) mod_ssl-2.0.40-8

Questions:
Is there some good howto info out there for 2.0 other than what's on
apache.org and the O'Reilly book?

Would I be better off downgrading or putting the latest Apache in from
source?

If I put the latest in from source is it likely I'll have to upgrade all
the depends, and will that propagate further?

Thanks in advance,

John











[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]