[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

gnome doesn't let NFS users login.



I have 2 servers both running Redhat 8.0, kernel 2.4.20-20.8smp.
Users with their homes on one of the servers can't login using gnome.
The message that appears is 
  "could not lock the file ...../gconf-test-locking-file.......
   the error was 'no locks available' errno = 37"
with some bits missed out.
Strange, but it seems that users with their home on the other server 
can login using gnome.

My servers *are* running rpc.statd and rpc.lockd and the odd thing is 
that when the user has clicked on ok to get rid of the error message, 
I notice that their home directory has been mounted fine(using the 
automounter).
So why is gnome having a problem?
What I see on the server with the problem is this in 
/var/log/messages:

  shakti kernel: RPC: Can't bind to reserved port (98).
  shakti kernel: lockd: cannot monitor 137.195.15.43

I've had a look on the net and I've seen someone suggest that it's a 
bug in gnome, and it could be fixed by putting the 2 dirs, .gconf and 
.gconfd, on a local disk and making symbolic links to this from the 
NFS mounted file system. I tried this as an experiment but it didn't 
work - still got the same error message. Even if it allow me to login 
then it still wouldn't help as i have hundreds of users who need the 
NFS mounted home directories to work under gnome.

Can someone tell me how to fix this?
Thanks in advance,

Ross

--
Ross Macintyre
Heriot-Watt University
raz macs hw ac uk




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]