[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: viewing/editing files at SMB locations

> I have enabled myself to use root passwords so that I don't have to
> su first. 500 and 501 are my UID/GID numbers respectively.
> What I find interesting is that even although I specifically state
> that the mounted files/directories are to be owned by me, the files
> still get owned by root, which means I can read the share but 
> can't write to it as a normal user. Is there anyway I can force
> the smb filesystem contents to be owned by me once mounted?

Try gid and uid.
You can also use fmask and dmask to set permissions...

# /usr/bin/sudo /usr/bin/smbmount  //maxxsrv/maxxess /mnt/smbmnt -o

> B.T.W. This share is a Windows server shared by all of the employees
> here. I wanted to be more specific by mounting the share 
> ..maxxsrv/Staff Directories/Jason, but the smbmount command could
> not find that share, and it does exist! I tried quoting "Staff
> Directories" and that didn;t work either. I have been at this for over 2
> hours now and still no joy. Any suggestions?

You can't mount ..maxxsrv/Staff Directories/Jason since it's not a
share, it's a subdirectory of a share. Perhaps you can create the mount
to the share, and then create a soft link to the subdirectory you want
to use ?

Attachment: signature.asc
Description: This is a digitally signed message part

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]