[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Dell Dimension 4600 NIC problem

My new Dell Dimension 4600 has "integrated Audio and NIC" neither of which 
were identified when RH8.0 was installed.

Despite sustained effort I cannot install these functions. I have been told by
people in user groups that the NIC takes an Intel e1000 driver, however there 
is no confirmation that this is actually the case. I have written to my Dell 
vendor asking for information on the motherboard and NIC, but they have not 
yet replied. In windows the network card has a driver called Intel PRO/100 
VE. I have tried installing various linux drivers from source, using 
downloads from the Intel site:
e1000-4.3.15.tar.gz     e1000-4.4.19.tar.gz  e1000-5.1.13.tar.gz

In most cases the sequence of commands including make install seem to run
normally, and as expected the e1000.o driver (size 84K) is installed in

I have added alias eth0 e1000 to /etc/modules.conf.
When I try to use the module:
[root localhost net]# insmod e1000
Using /lib/modules/2.4.18-18.8.0/kernel/drivers/net/e1000/e1000.o
/lib/modules/2.4.18-18.8.0/kernel/drivers/net/e1000/e1000.o: init_module: No
such device.

Linux always looks for the module in the above e1000 directory, which was 
created but is empty, as the newly compiled module is located in the above net
directory. Is this a clue? I also tried the e100 driver - same result.

The fact that Dell sells PCs without information or drivers necessary to 
install linux is annoying, however I know I just have to get over it.

Any suggestions will be very much appreciated. I am near the point of buying a
cheap NIC PCI card as I have spare slots, however such a move is pretty


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]