[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RPM hangs



On Fri, 29 Aug 2003 08:52:47 +0200 Jason Dale <redhat maxxess co za> 
wrote:

> Thanks for the info y'all :)
> 
> Micheal, I know the term 'lock files' should be fairly 
> obvious, but what exactly do these files 'lock' ? 
> where can I find more info on these?

I don't know the answer to this, but I have lots of trouble with rpm 
so I thought I'd just share my views. (I would also be interested in 
finding out more about these 'lock' files).
I am looking after about 200 linux machines and am trying to keep 
about 70 RedHat 8.0 machines up-to-date with the RPMs. I simply run a 
script that checks all the machines rpm's and compares them against 
one particular machine. When I get an update to do I run a script 
that basically updates the rpm(s) on all the machines in turn. 
What I have found is that more and more frequently the script hangs 
and I have to remote log into a particular machine and kill -9 the 
process and let the script continue. Quite often the rpm database on 
the particular machine is wrong I have to add or remove rpms 
accordingly.

Anyway, recently I thought I might remake the rpm database 
(removing the __db.00* files and running rpm --rebuilddb) on all my 
machines thinking this might be the problem, but I am still getting 
more and more machines hanging. I have even run the script using 
'rpm -Fvvvh' and looking at the verbose output to see if there was 
something obvious that was causing the problem, but couldn't see 
anything.
The only other thing I can think of is that my rpm ffiles live on a 
server and I access them through the automounter, and maybe this 
causes some sort of problem if a packet is dropped or 
something(clutching at straws here maybe)

I also looked after about 130 7.1 machines but never found the 
problem to be quite as bad as it is with the 8.0 machines. maybe rpm 
is just crap in 8.0??

Anyway that's my 2p worth:-)

Hope it helps, or someone can enlighten me!!
Cheers,
Ross
> 
> Thanks a stack, 
> 
> Jason
> 
> ----- Original Message ----- 
> From: "Michael Fratoni" <mfratoni tuxfan homeip net>
> To: <psyche-list redhat com>
> Sent: Friday, August 29, 2003 3:11 AM
> Subject: Re: RPM hangs
> 
> 
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> > 
> > On Thursday 28 August 2003 12:15 pm, dave c wrote:
> > > I know this may not be much to add, but I have had this happen to me
> > > and a simple reboot solved the problem.  Of course that might make me
> > > appear that I'm in the same group as those windoze losers, but
> > > hey...just thought I would let you know that worked for me.
> > >
> > > rpm -rebuilddb wouldn't respond, as well as any other rpm command. 
> > > Something magical must be happening to the rpm database at
> > > bootup...would be nice to know what it is.
> > 
> > The magic that happens at boot time is nothing more than removing the 
> > stale lock files. "rm -f /var/lib/rpm/__db*" 
> > 
> > 
> > - -- 
> > - -Michael
> > 
> > pgp key:  http://www.tuxfan.homeip.net:8080/gpgkey.txt
> > Red Hat Linux 7.{2,3}|8.0|9 in 8M of RAM: http://www.rule-project.org/en/
> > - --
> > -----BEGIN PGP SIGNATURE-----
> > Version: GnuPG v1.0.7 (GNU/Linux)
> > 
> > iD8DBQE/TqhYn/07WoAb/SsRAiz6AJ9HjLYr9KiICLB16ibOBC+toe//QgCgo/FS
> > zQyMLwinnz5RnmGiZQV8hVc=
> > =aSt6
> > -----END PGP SIGNATURE-----
> > 
> > 
> > -- 
> > Psyche-list mailing list
> > Psyche-list redhat com
> > https://www.redhat.com/mailman/listinfo/psyche-list
> 
> 
> -- 
> Psyche-list mailing list
> Psyche-list redhat com
> https://www.redhat.com/mailman/listinfo/psyche-list

--
Ross Macintyre
Heriot-Watt University
raz macs hw ac uk




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]