[Pulp-dev] Pulp3 Plugin API SemVer Strategy

Bihan Zhang bizhang at redhat.com
Thu Jun 1 15:18:56 UTC 2017


I've been documenting the plugin API semver strategy for 3.0 but I've
noticed that the plugins were recently moved from plugin/pulp/plugin to
platform/pulp/plugin

My understanding was that we would have separate packages for plugin and
platform to enforce the separate semantic versioning, instead of just
having documentation on the plugin version supported by platform.

I think the correct workflow is for a plugin writer would denote in their
spec file (or setup.py) what pulpcore-plugin versions are supported, and on
installation the package manager can pull in the correct pulpcore-plugin
package with the correct platform dependency.


I wanted to check that this was everyone else's understanding too.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-dev/attachments/20170601/65613296/attachment.htm>


More information about the Pulp-dev mailing list