[Pulp-dev] DRF 3.7.0 Issues

Dennis Kliban dkliban at redhat.com
Fri Oct 6 23:16:51 UTC 2017


I put in a PR[0] to fix the actual incompatibility.

[0] https://github.com/pulp/pulp/pull/3186

On Fri, Oct 6, 2017 at 2:40 PM, Brian Bouterse <bbouters at redhat.com> wrote:

> 2.6.4  should have read   3.6.4
>
> On Fri, Oct 6, 2017 at 2:37 PM, Brian Bouterse <bbouters at redhat.com>
> wrote:
>
>> Today DRF pushed 3.7.0 to PyPI which breaks the pulp, the docs builders
>> and vagrant environments. This issue is tracked here [0] along with a
>> workaround for your vagrant environment.
>>
>> I think we should triage [0] onto the sprint w/ high prio. Should we?
>>
>> The resolution of [0] is to update Pulp to be 3.7.0 compatible right?
>>
>> In the meantime @daviddavis and I fixed the docs builders by pinning them
>> to 2.6.4 and pushing the config using JJB. There is still this PR [2] which
>> pins core to 2.6.4 also, so we should merge that too right?
>>
>> Even if we do merge [2] the ansible is still broken if someone knows the
>> answer to this [3].
>>
>> [0]: https://pulp.plan.io/issues/3057
>> [1]: https://github.com/pulp/pulp_packaging/pull/436/files
>> [2]: https://github.com/pulp/pulp/pull/3185/files
>> [3]: https://pulp.plan.io/issues/3057#note-3
>>
>
>
> _______________________________________________
> Pulp-dev mailing list
> Pulp-dev at redhat.com
> https://www.redhat.com/mailman/listinfo/pulp-dev
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-dev/attachments/20171006/7ee794a6/attachment.htm>


More information about the Pulp-dev mailing list