[Pulp-dev] Issue #4432:<Pulp upgrade from 2.7 to 2.18 logs says Database initialization failed>

Madavarapu, Yashwanth (ETW - Cognizant) Yashwanth.Madavarapu at nike.com
Thu Mar 14 14:01:51 UTC 2019


Hi Team,

Continuing to the Issue 4432,I have below questions. Can someone clarify it.

1.We have a production db of 70GB,when we are doing upgrade from version to version i.e., from 2.7 to 2.8 and 2.8 to 2.9 and so on up to 2.18.How much time it would take to for pulp-manage-db to  migrate dB once we upgrade from 2.7 to 2.8 during its first run of “sudo -u apache pulp-manage-db”, we wanted to have an estimate  how much time it would take as it has multiple versions that need to be upgraded. It would be helpful if we can get info on this so we can plan the downtime for the application.
2.Is it ok to have Pulp version upgraded to 2.18 with mongodb running with 2.6.
3.What are the best ways to stop the pulp services, as we have multiple components running on multiple servers. As far I am aware it is best to stop the apache,resourcemanager and worker services once all are done we can bring down the mongodb services. Please let me know if there is any other order to stop the services.

Thanks for daviddavis<https://pulp.plan.io/users/51> for responding to my queries in the issue initially.


Thanks,
Yash


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-dev/attachments/20190314/39725bf6/attachment.htm>


More information about the Pulp-dev mailing list