[Pulp-dev] renaming user facing fields on content serializers
daviddavis at redhat.com
Tue Sep 10 10:13:05 UTC 2019
I agree. Can you open an issue?
On Tue, Sep 10, 2019 at 4:39 AM Matthias Dellweg <dellweg at atix.de> wrote:
> TL;DR: Should the fields "_relative_path" and "_artifact" on the
> SingleArtifactSerializer be renamed to "relative_path" and "artifact"
> While working on the upload create content serializer story , i
> noticed, that there are two fields on the
> SingleArtifactContentSerializer with unnecessary complicated names
> ("_artifact" and "_relative_path"). In fact, all descendent
> serializers, i know of take some hurdle  to rename "_relative_path"
> back to "relative_path".
> I believe, the leading underscore was added for a convention, that
> pulpcore controlled database fields should not take names (like "href"),
> that may be needed by plugins to represent a domain specific api.
> I think, the naming here is taking this convention one step too far in
> that the serializers themselves are merely a convenience layer for the
> plugin writer, and those serializer fields do not directly correspond
> to database fields on any content model. Moreover the file plugin turns
> "relative_path" (without "_") into a real database field, and given the
> name is seems safe to use a relative_path_validator on a string field
>  https://pulp.plan.io/issues/5403?pn=1#note-4
> Pulp-dev mailing list
> Pulp-dev at redhat.com
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pulp-dev