jortel at redhat.com
Wed Mar 9 16:18:38 UTC 2011
After working through the "Update Semantics" story is seemed to me the
proposed update signature:
was kind of odd. It was originally proposed this way to be more comparable with how the
update() was being used whereby a model object was begin passed. Now that semantics have
been changed and a dictionary (delta) of changed fields and/or keywords is passed, it
seems to make more sense to pass the object ID separate and *not* in the delta.
So, unless there are objections, I'm changing the signature to be:
However, I am bullet proofing the impls to ignore the 'id' within the 'delta'.
More information about the Pulp-list