[Pulp-list] using --interval

Joe Hoot joehoot at gmail.com
Thu May 19 18:50:42 UTC 2011

After spending awhile trying to figure out why I couldn't get oracle-xe to work properly in x86_64 environment for spacewalk, I reinstalled using 32-bit.  After that, I was able to get past my oracle-xe pre-reqs.  But then I ran into a conflict with what Oracle ships for their up2date package and what spacewalk expects to use.  So I'm done with attempting to test spacewalk for the time being and back to pulp.

So I enabled the testing repo and tried my command again and get the following:

[root at pulp yum.repos.d]# pulp-admin repo create --id fedora-pulp --feed yum:http://repos.fedorapeople.org/repos/pulp/pulp/fedora-6Server/x86_64/ --interval R5//P1D
Unable to parse duration string 'R5//P1D'

[root at pulp yum.repos.d]# rpm -qa | grep pulp
[root at pulp yum.repos.d]# 

The documentation on the wiki seems to suggest that you don't need to put a start date in there.  Does the syntax above seem like it should work?

Also, does anyone see any requirements in pulp that would prevent me from using it in a mixed RHEL clone environment (some RHEL, some CentOS, some OEL systems)?


On May 19, 2011, at 7:19 AM, Todd B Sanders wrote:

> On 05/18/2011 11:24 PM, Joe Hoot wrote:
>> I'm just starting to play with pulp and am attempting to set it up.  I've noticed that the fedorapeople.org repos seemed to be difficult for me to pull from.  So I was going to pull down the repo locally so that I could more easily distribute the pulp-client.  And although I can create the repo without --interval just fine, I would like to have a schedule setup to have it sync once a day.
>> So here is what I tried:
>> [root at pulp ~]# pulp-admin repo create --id fedora-pulp --feed yum:http://repos.fedorapeople.org/repos/pulp/pulp/fedora-6Server/x86_64/ --interval R5//P1D
>> Usage: pulp-admin<options>  repo create<options>
>> pulp-admin: error: no such option: --interval
>> [root at pulp ~]# rpm -qa | grep pulp
>> pulp-common-0.0.173-1.el6.noarch
>> pulp-0.0.173-1.el6.noarch
>> pulp-client-0.0.173-1.el6.noarch
>> pulp-cds-0.0.173-1.el6.noarch
>> [root at pulp ~]#
>> Is that option not available yet?
>> _______________________________________________
>> Pulp-list mailing list
>> Pulp-list at redhat.com
>> https://www.redhat.com/mailman/listinfo/pulp-list
> Joe:
> The ISO18601 refactor and repo scheduling functionality is not in the current Community Release (CR#11).  The next Community Release (CR#12) is scheduled for next week; this release will include this updated functionality.  That said, your welcome to pull 0.178 from our Testing Repo (http://repos.fedorapeople.org/repos/pulp/pulp/testing/6Server/x86_64/) to trial this functionality.
> Thanks!
> -Todd

More information about the Pulp-list mailing list