[Pulp-list] Pulp-Admin timeout

Tata, Joseph joseph.tata at www.colorado.gov
Thu Dec 12 21:31:27 UTC 2013

I have a newly installed Pulp 2.3 server which will not respond to admin client commands.  When I run any pulp-admin command I get the following error:

An error occurred attempting to contact the server. More information can be
found in the client log file ~/.pulp/admin.log.

admin.log file contains the following:

2013-12-12 14:03:21,766 - ERROR - Client-side exception occurred
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pulp/client/extensions/core.py", line 478, in run
    exit_code = Cli.run(self, args)
  File "/usr/lib/python2.6/site-packages/okaara/cli.py", line 974, in run
    exit_code = command_or_section.execute(self.prompt, remaining_args)
  File "/usr/lib/python2.6/site-packages/pulp/client/extensions/extensions.py", line 224, in execute
    return self.method(*arg_list, **clean_kwargs)
  File "/usr/lib/python2.6/site-packages/pulp/client/admin/admin_auth.py", line 58, in login
    result = self.context.server.actions.login(username, password).response_body
  File "/usr/lib/python2.6/site-packages/pulp/bindings/actions.py", line 32, in login
    return self.server.POST(path)
  File "/usr/lib/python2.6/site-packages/pulp/bindings/server.py", line 102, in POST
    return self._request('POST', path, body=body, ensure_encoding=ensure_encoding)
  File "/usr/lib/python2.6/site-packages/pulp/bindings/server.py", line 146, in _request
    response_code, response_body = self.server_wrapper.request(method, url, body)
  File "/usr/lib/python2.6/site-packages/pulp/bindings/server.py", line 295, in request
    connection.request(method, url, body=body, headers=headers)
  File "/usr/lib64/python2.6/httplib.py", line 914, in request
    self._send_request(method, url, body, headers)
  File "/usr/lib64/python2.6/httplib.py", line 951, in _send_request
  File "/usr/lib64/python2.6/httplib.py", line 908, in endheaders
  File "/usr/lib64/python2.6/httplib.py", line 780, in _send_output
  File "/usr/lib64/python2.6/httplib.py", line 739, in send
  File "/usr/lib64/python2.6/site-packages/M2Crypto/httpslib.py", line 50, in connect
    self.sock.connect((self.host, self.port))
  File "/usr/lib64/python2.6/site-packages/M2Crypto/SSL/Connection.py", line 181, in connect
  File "<string>", line 1, in connect
error: [Errno 110] Connection timed out

I have tried every variation for host in /etc/pulp/admin/admin.conf that I can think of (including hostname, fqdn, localhost, and IP).  I've also turned off selinux and iptables.  I can access my web server on both 80 and 443 but can't find if the pulp webservice API is running or not.

What else could I check?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-list/attachments/20131212/cda6ba2b/attachment.htm>

More information about the Pulp-list mailing list