[Pulp-list] Questions about "distributions" and "yum repo metadata files"

Baird, Josh jbaird at follett.com
Mon Dec 16 16:27:26 UTC 2013


For what it's worth, I sync the rhel6-server repo nightly (from cdn.redhat.com) and my distributions are working correctly:

Id:                  rhel5-server-x86_64
Display Name:        rhel5-server-x86_64
Description:         None
Content Unit Counts:
  Distribution:           1
  Erratum:                2856
  Package Category:       6
  Package Group:          99
  Rpm:                    8172
  Yum Repo Metadata File: 1

Id:                  rhel6-server-x86_64
Display Name:        rhel6-server-x86_64
Description:         None
Content Unit Counts:
  Distribution:           1
  Erratum:                2243
  Package Category:       10
  Package Group:          202
  Rpm:                    8165
  Yum Repo Metadata File: 1

I did notice that my distributions have not been updated to 6.5/5.10, but I have not actually verified and tested this yet:

root at fc-d1pulp01:/var/lib/pulp/content/distribution$ ll
total 8
drwxrwxr-x 4 apache apache 4096 Nov 12 08:11 ks-Red Hat Enterprise Linux Server-5.9-x86_64
drwxrwxr-x 3 apache apache 4096 Nov 20 18:12 ks-Red Hat Enterprise Linux-Server-6.4-x86_64

There was a bug with the RHEL5 distribution on cdn.redhat.com that was causing syncs to fail, however this was recently fixed.  We are running Pulp 2.3.0-final.  Regarding Oracle Linux 6; syncing via Pulp to their repos is currently broken [1].  Hopefully, this will get fixed soon.

[1] - https://bugzilla.redhat.com/show_bug.cgi?id=1039597



From: pulp-list-bounces at redhat.com [mailto:pulp-list-bounces at redhat.com] On Behalf Of Christina Plummer
Sent: Monday, December 16, 2013 11:12 AM
To: Barnaby Court
Cc: pulp-list at redhat.com
Subject: Re: [Pulp-list] Questions about "distributions" and "yum repo metadata files"

Hi Barnaby,
Thanks a lot for your reply - I got swamped last week and didn't get an opportunity to circle back on this until today, so I apologize for the delay.
1. I am still trying to understand what a "distribution" is.  It sounds like what defines a distribution is the existence of an upstream treeinfo file - is that right?  Why would a repository created from install media not also be a distribution?  Is there just no method for importing boot images at this point?
2. When you say that distributions are required for kickstart - is that just if you need to use PXE to boot?  If you were booting in some other way, I can't think why the treeinfo, etc. would be required for install.
3. Regarding the "Yum Metadata Files" - so those would only exist if the upstream repositority had a repomd/ directory - not a repodata/ ?  When I create a new repo and publish it, there is (of course) a repodata/ created - what is the difference between this and "Yum Metadata Files" as listed by Pulp?
4. I don't see any treeinfo in the Oracle upstream repository, so that makes sense that I don't have a distribution there.
5. I can't easily browse the Red Hat repositories, due to the certificates required - I would expect that the 5.10 and 6.5 distributions would be there now, but when I sync I am not getting them.  It also looks like I had 5.9 and 6.4 at one time (based on the files under /var/lib/pulp/content/distributions), but as you can see from my repolist output below, the 6.4 distribution is not being listed any more.

I made a copy of everything (including the distribution) from my RHEL6 repo before I synced it on 12/2 (the last time it was synced before that was probably September).  The copied repo still shows the 6.4 distribution present.  But the one that is fed from RH no longer has that one - and 6.5 is not there either.

Slightly differently, my RHEL5 repo seems to contain the 5.9 distribution, but 5.10 hasn't shown up.  My feed URLs are:

I did get some 404 errors when I tried to sync RHEL5 again this morning on these files, though it showed "Tree Files: 6/6 items":

The RHEL6 repo didn't have any errors on the sync but still no distribution - is showed 0/0 items for Tree Files.

Please let me know if I can provide more information that would be helpful.


On Wed, Dec 11, 2013 at 2:04 PM, Barnaby Court <bcourt at redhat.com<mailto:bcourt at redhat.com>> wrote:
Hi Chris,

You have a few questions in here so I'll try to hit all of them.  V2 definitely supports distributions.  Distributions are required for kickstart.  I'm not sure why you would be seeing the listing for a distribution type if there is no treeinfo file in the upstream repository.  If you have a treeinfo file in the upstream repository you should have a distribution created in your repository in pulp.  Copying the distribution from one repo to another should work.  Creating a distribution by hand and uploading to a repository in pulp is not currently supported.  However, if the upstream repository has a distribution it should be synced automatically and can then be copied from one pulp-repo to another.

API information about distributions can be found at: http://pulp-rpm-dev-guide.readthedocs.org/en/latest/yum-plugins.html#distribution

The yum repo metadata files (generally) are the files in the /repomd/ subdirectory of a repository.  They contain information about the repository ant its contents.

My primary concern would be if you are syncing a repo that has a treeinfo or .treeinfo file upstream and you are not getting a distribution in your pulp repo.  RHEL 6.4 absolutely does have a treeinfo included in the CDN and we use it for testing regularly.  If you are running into trouble there I definitely want to know about it.



----- Original Message -----
From: "Christina Plummer" <cplummer at gmail.com<mailto:cplummer at gmail.com>>
To: pulp-list at redhat.com<mailto:pulp-list at redhat.com>
Sent: Wednesday, December 11, 2013 10:47:07 AM
Subject: [Pulp-list] Questions about "distributions" and "yum repo metadata     files"

Hello all,

I am using Pulp 2.1.3. I've created a few feeds synced from vendor repos (Oracle and Red Hat), and then have been creating clones (copies) of those repos to use as a stable "patch set" for each release by copying each of the content types. I've noticed that the repos synced from Red Hat display content types of "Distribution" and "Yum Repo Metadata File", while the ones from Oracle do not. Also, I've noticed that the RHEL5 repo actually contains a Distribution, while the RHEL6 repo shows the content type but with a count of 0:

Id: live-rhel-6-x86_64-os
Display Name: live-rhel-6-x86_64-os
Description: None
Content Unit Counts:
Distribution: 0
Erratum: 2228
Package Category: 10
Package Group: 201
Rpm: 3788
Yum Repo Metadata File: 1

I found these files:
/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux Server-5.9-x86_64/treeinfo
/var/lib/pulp/content/distribution/ks-Red Hat Enterprise Linux-Server-6.4-x86_64/treeinfo

I found this documentation from Pulp v1 discussing Distributions:

But I couldn't find any reference to Distributions or Yum Repo Metadata Files in the Pulp v2 documentation at all.

Is there a good explanation of these somewhere? Do I need the distribution in order to kickstart? If I wanted to create one in each of my cloned repos for the distros that were missing from the vendor feeds, how would I do that?

Also, what is the yum repo metadata file?

Thanks for any assistance in understanding.

Pulp-list mailing list
Pulp-list at redhat.com<mailto:Pulp-list at redhat.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-list/attachments/20131216/852e3dac/attachment.htm>

More information about the Pulp-list mailing list