[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Pulp-list] Local Pulp server for client app development?

On 26 August 2015 at 16:56, Nick Coghlan <ncoghlan gmail com> wrote:
> Unfortunately, I still end up stuck waiting for mongodb. I even tried
> "sudo setenforce 0" and still get stuck there. I'll keep digging :)

Getting a lot closer now. Another key piece of the puzzle was finding
this bug regarding issues with container linking in Fedora's docker
1.7.1 RPM: https://bugzilla.redhat.com/show_bug.cgi?id=1244124

Updating to the docker 1.8.1 RPM in Fedora 22's testing repo resolved that.

The customised version of the launch script I'm now using is
(that has the changes to sprinkle ":Z" on all the mount commands, as
well as attempting to make the script still runnable when the
containers all exist, but aren't currently running)

The last remaining issue appears to be the "beat" container failing to
launch, getting a permission denied error when it tries to write out
"/var/lib/pulp/celery/celerybeat.pid". I haven't started digging into
that one yet.


Nick Coghlan   |   ncoghlan gmail com   |   Brisbane, Australia

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]