[Pulp-list] Stuck repo sync job

Brian Bouterse bbouters at redhat.com
Fri Apr 8 18:27:12 UTC 2016

I'm not sure how you would get into this situations. When it occurs can
you check which worker is assigned the work, and verify that that worker
is still running?

Upon starting a worker will move previous tasks it was handling that are
still in the running state to cancelled. Also pulp_celerybeat monitors
pulp workers to determine if died to move its tasks to a cancelled
state. Both of these mechanisms would have to fail in order to have a
task stay in the running state when its not running. Could it still be

You indicate you rebooted the box and those tasks didn't go to
cancelled. Is it possible they are on another box connected to your
broker or when killing them it didn't respond to the signal you sent it?

The 2.7.1 doesn't have any known defects like the ones your describing
so sending more info to the list would be good.


On 03/30/2016 05:58 PM, Matthew Madey wrote:
> I have a job that mistakenly thinks it's still running..
> # pulp-admin -u admin -p ************ rpm repo sync run
> --repo-id=rhel-x86_64-server-7-base-tools
> +----------------------------------------------------------------------+
>        Synchronizing Repository [rhel-x86_64-server-7-base-tools]
> +----------------------------------------------------------------------+
> A sync task is already in progress for this repository. Its progress will be
> tracked below.
> This command may be exited via ctrl+c without affecting the request.
> [/]
> Waiting to begin...
> I checked all running processes and there is no repo sync currently
> running. I have even gone so far as to delete the repo and recreate it..
> same issue. I have also tried running pulp-admin orphan remove --all,
> which executes successfully, but does not fix the problem. I have also
> tried rebooting the server, bouncing all pulp services.. still no joy.
> I'm guessing there is a file somewhere that tracks pending tasks? How
> can I clear this so I can successfully run the job again? I'm running
> Pulp 2.7.1-1
> _______________________________________________
> Pulp-list mailing list
> Pulp-list at redhat.com
> https://www.redhat.com/mailman/listinfo/pulp-list

More information about the Pulp-list mailing list