[Pulp-list] Stuck repo sync job

Matthew Madey mattmadey at gmail.com
Wed Mar 30 21:58:45 UTC 2016

I have a job that mistakenly thinks it's still running..

# pulp-admin -u admin -p ************ rpm repo sync run
       Synchronizing Repository [rhel-x86_64-server-7-base-tools]

A sync task is already in progress for this repository. Its progress will be
tracked below.

This command may be exited via ctrl+c without affecting the request.

Waiting to begin...

I checked all running processes and there is no repo sync currently
running. I have even gone so far as to delete the repo and recreate it..
same issue. I have also tried running pulp-admin orphan remove --all, which
executes successfully, but does not fix the problem. I have also tried
rebooting the server, bouncing all pulp services.. still no joy. I'm
guessing there is a file somewhere that tracks pending tasks? How can I
clear this so I can successfully run the job again? I'm running Pulp 2.7.1-1
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-list/attachments/20160330/f73b8b9a/attachment.htm>

More information about the Pulp-list mailing list