[Pulp-list] Stuck repo sync job

Ina Panova ipanova at redhat.com
Thu Mar 31 09:14:43 UTC 2016

Hello Matthew,

you can see all pending task by doing:

# pulp-admin tasks list --state=waiting

You will need to cancel those queued waiting tasks triggered for sync of the repo :

pulp-admin tasks cancel --task-id <task-id>

That should solve your issue.


Ina Panova
Software Engineer| Pulp| Red Hat Inc.

"Do not go where the path may lead,
 go instead where there is no path and leave a trail."

----- Original Message -----
From: "Matthew Madey" <mattmadey at gmail.com>
To: pulp-list at redhat.com
Sent: Wednesday, 30 March, 2016 11:58:45 PM
Subject: [Pulp-list] Stuck repo sync job

I have a job that mistakenly thinks it's still running.. 

# pulp-admin -u admin -p ************ rpm repo sync run --repo-id=rhel-x86_64-server-7-base-tools 
Synchronizing Repository [rhel-x86_64-server-7-base-tools] 

A sync task is already in progress for this repository. Its progress will be 
tracked below. 

This command may be exited via ctrl+c without affecting the request. 

Waiting to begin... 

I checked all running processes and there is no repo sync currently running. I have even gone so far as to delete the repo and recreate it.. same issue. I have also tried running pulp-admin orphan remove --all, which executes successfully, but does not fix the problem. I have also tried rebooting the server, bouncing all pulp services.. still no joy. I'm guessing there is a file somewhere that tracks pending tasks? How can I clear this so I can successfully run the job again? I'm running Pulp 2.7.1-1 

Pulp-list mailing list
Pulp-list at redhat.com

More information about the Pulp-list mailing list