[Pulp-list] Stuck repo sync job

Miller, Jeffrey L jeff-l-miller at uiowa.edu
Thu Mar 31 14:11:05 UTC 2016

I cancel the tasks as well... except it seems more common for me so I have a cron job running a script every 30 minutes to check for pending sync jobs and resubmit the sync job for the repo. 


Jeffrey Miller
Senior Systems Administrator
The University of Iowa
ITS - Enterprise Infrastructure
23 Lindquist Center South
Iowa City, IA 52242-1727
(319) 384-3655

-----Original Message-----
From: pulp-list-bounces at redhat.com [mailto:pulp-list-bounces at redhat.com] On Behalf Of Richard Grainger
Sent: Thursday, March 31, 2016 5:49 AM
To: Matthew Madey <mattmadey at gmail.com>
Cc: pulp-list <pulp-list at redhat.com>
Subject: Re: [Pulp-list] Stuck repo sync job

When Pulp (very occasionally) gets itself in a bit of a mess, I find this one-liner useful:

  for ID in `pulp-admin tasks list | grep 'Task Id' | sed 's/Task Id:\s*//g'`; do pulp-admin tasks cancel --task-id=$ID; done;

It cancels all current/pending tasks.

On Wed, Mar 30, 2016 at 10:58 PM, Matthew Madey <mattmadey at gmail.com> wrote:
> I have a job that mistakenly thinks it's still running..
> # pulp-admin -u admin -p ************ rpm repo sync run 
> --repo-id=rhel-x86_64-server-7-base-tools
> +----------------------------------------------------------------------+
>        Synchronizing Repository [rhel-x86_64-server-7-base-tools]
> +----------------------------------------------------------------------+
> A sync task is already in progress for this repository. Its progress 
> will be tracked below.
> This command may be exited via ctrl+c without affecting the request.
> [/]
> Waiting to begin...
> I checked all running processes and there is no repo sync currently running.
> I have even gone so far as to delete the repo and recreate it.. same issue.
> I have also tried running pulp-admin orphan remove --all, which 
> executes successfully, but does not fix the problem. I have also tried 
> rebooting the server, bouncing all pulp services.. still no joy. I'm 
> guessing there is a file somewhere that tracks pending tasks? How can 
> I clear this so I can successfully run the job again? I'm running Pulp 
> 2.7.1-1
> _______________________________________________
> Pulp-list mailing list
> Pulp-list at redhat.com
> https://www.redhat.com/mailman/listinfo/pulp-list

Pulp-list mailing list
Pulp-list at redhat.com

More information about the Pulp-list mailing list