[Pulp-list] ERROR: requested data type primary not available

Rolf Loudon kalischt at gmail.com
Wed Jul 24 06:51:29 UTC 2019


I have created and synced a repository in pulp.  

pulp-admin repo list shows it as follows:

Id:                  rhel-6-server-rpms

Display Name:        None

Description:         None

Content Unit Counts: 

  Erratum:                4324

  Package Category:       10

  Package Group:          202

  Rpm:                    20785

  Yum Repo Metadata File: 1

I have a (old) spacewalk server on which I defined the above repo as a repository source. However when I try to sync the repo into spacewalk I get this:

06:44:11 Sync of channel started.

06:44:11 Repo URL: http://xxxxxxxxxx/pulp/repos/rhel-6-server-rpms

06:44:11 ERROR: requested datatype primary not available

06:44:11 Sync of channel completed in 0:00:00.

06:44:11 Total time: 0:00:00

To eliminate spacewalk as the source of the problem I configured a server that has never before used the pulp repo in /etc/yum.repos.d/pulp.repo :


name=Red Hat Enterprise Linux Pulp $releasever - $basearch



When I run ‘yum repolist’ it fails in the same way:

# yum repolist

Loaded plugins: priorities, protectbase, refresh-packagekit, rhnplugin

This system is receiving updates from RHN Classic or Red Hat Satellite.

Error: requested datatype primary not available

I have tried numerous times to recreate the repo in pulp and resync and so on.  

Any assistance much appreciated. 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/pulp-list/attachments/20190724/be5fea7f/attachment.htm>

More information about the Pulp-list mailing list