[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] Why use yum priority in rdo-release repo file?



On 20/06/13 17:06, Karanbir Singh wrote:
>> 
>> yum prioritizes packages with shorter names, thus would install
>> Django instead of Django14. (version 1.3 vs. 1.4).
>> 
> 
> This looks like a bad Requires: line in the RDO packaging. Yum wont 
> install Django 1.3 when your baseline Requires: >= 1.4 and Django14 
> should provide Django = 1.4
> 
No.

Django14 provides:
Provides:       Django = %{version}-%{release}

Horizon requires
%if 0%{?rhel}==6
Requires:   Django14

So, it is like you requested.

The problem here is: Horizon requires e.g python-django-compressor,
which also works on Django 1.3. So you just can put there requires:
Django, when requiring there Django14 or Django >= 1.4, you'll break
other installations.
In this case, yum tries to install both, Django14 and Django, which
produces a conflict. Having both, does not make sense at all. So,
parallel installable versions don't help here.

Matthias


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]