[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] RDO installation failed on keystone



(moving thread to rdo-list)

On 06/24/2013 11:57 AM, Tal Kammer wrote:
> I just tried to install a fresh copy of the RDO on a machine using packstack (followed: http://openstack.redhat.com/Quickstart) when it failed on the keystone component saying that there is a dependency issue with python-sqlalchemy.
> After checking the subject, it seems that the repo has sqlalchemy version 0.5 where the keystone component requires version 0.7+
> 
> Can someone confirm this?
> 
> (to reproduce this, just follow the installation procedure on the link above)

EPEL should have sqlalchemy 0.7 as far as I can see:

http://dl.fedoraproject.org/pub/epel/6/x86_64/repoview/python-sqlalchemy0.7.html

What repos do you have enabled on your RDO install machine?

Base RHEL does indeed have an older version of sqlalchemy, which is why
RHOS repos contain a newer version and RDO requires EPEL version of the
package

> python-sqlalchemy.noarch             0.5.5-3.el6_2            rhel-released     
> python-sqlalchemy0.7.x86_64          0.7.8-1.el6              epel              
> python-sqlalchemy0.7.x86_64          0.7.8-1.el6ost           rhos3

Perry


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]