[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Rdo-list] [rdo-manager] - unable to get password from heira

i am still hitting this issue
and it seems its been around for a while see https://www.redhat.com/archives/rdo-list/2015-December/msg00000.html

and i'd rather not do the dirty hack mentioned in that thread

where should i file this bug?


On Wed, Dec 16, 2015 at 9:27 AM, Pedro Sousa <pgsousa gmail com> wrote:
Ok, so I fixed it thanks to trown on irc, excluding hiera from epel.repo.

On Tue, Dec 15, 2015 at 3:58 AM, Mohammed Arafa <mohammed arafa gmail com> wrote:
i was attempting to install rdo manager again tonight and was blocked.
i tried to figure it out and i do believe it is a path issue.

can someone confirm?

[stack rdomanager ~]$ sudo
+ OK_FILE=/opt/stack/.undercloud-setup
+ '[' -f /opt/stack/.undercloud-setup ']'
+ source /root/tripleo-undercloud-passwords
+++ sudo hiera admin_password
Failed to start Hiera: RuntimeError: Config file
/etc/puppetlabs/code/hiera.yaml not found
[stack rdomanager ~]$ ll  /etc/puppetlabs/code/hiera.yaml
ls: cannot access /etc/puppetlabs/code/hiera.yaml: No such file or directory
[stack rdomanager ~]$ cat /etc/puppet/hiera.yaml
  - json
  - yaml
  :datadir: /etc/puppet/hieradata
  :datadir: /etc/puppet/hieradata
  - "%{::osfamily}"
  - puppet-stack-config



* *


*Link to me on LinkedIn <http://www.linkedin.com/in/mohammedarafa>*

Rdo-list mailing list
Rdo-list redhat com

To unsubscribe: rdo-list-unsubscribe redhat com




Link to me on LinkedIn

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]