[Rdo-list] Max VM filesystem size?

Erich Weiler weiler at soe.ucsc.edu
Fri Nov 20 22:51:27 UTC 2015

Hi Y'all,

I have a bunch of OpenStack Nova nodes, each with 11TB of local disk for 
Cloud VMs.  This is all on RDO - RHEL 7 on OpenStack Kilo.  That local 
storage is configured with a XFS filesystem.

If I specify 8TB on 'root filesystem size' in a flavor, it only seems to 
be able to make a 2TB root filesystem on the guest.  No matter what 
guest OS I use (I've tried CentOS 7.1, Ubuntu 15.10, others) it only 
seems to be able to create a 2TB root filesystem.  I've also tried 
making a 5GB root filesystem and specifying 8TB for ephemeral disk, but 
the ephemeral disk that shows up on /tmp in the guest is only 2TB as well.

Is there a 2TB KVM limit on VM size?  Max file size in ext4 and XFS is 
well beyond 2TB, so I don't think that's it...  Maybe a limit in KVM or 

The qemu xml file on the node does specify a 8TB disk....

Any insight most welcome!!


More information about the rdo-list mailing list