[Rdo-list] OpenStack GPT Disk Label for VMs (was Re: Max VM filesystem size?)

Erich Weiler weiler at soe.ucsc.edu
Sat Nov 21 15:37:08 UTC 2015

Looks like there has been a little chatter on this topic:


I would guess the disk label is configured through nova somehow?  Maybe 
there would be a way I could patch in something to switch my default 
disk label to GPT, or somehow make it an option?

Has anyone run into this before?

On 11/20/15 3:37 PM, Erich Weiler wrote:
> Ah, it appears that the limit is 2TB because the VMs are created with a
> 'msdos' partition table on the virtual disks.  I think we need them to
> be 'gpt'....  parted shows the disks are big, just the filesystems are
> small:
> [centos at bigtest2 ~]$ sudo parted /dev/vda
> GNU Parted 3.1
> Using /dev/vda
> Welcome to GNU Parted! Type 'help' to view a list of commands.
> (parted) p
> Model: Virtio Block Device (virtblk)
> Disk /dev/vda: 10.7TB
> Sector size (logical/physical): 512B/512B
> Partition Table: msdos
> Disk Flags:
> Number  Start   End     Size    Type     File system  Flags
>   1      1049kB  1941GB  1941GB  primary  xfs          boot
> Still digging for info on how to use gpt with OpenStack/libvirt....
> Nothing yet...
> On 11/20/2015 02:51 PM, Erich Weiler wrote:
>> Hi Y'all,
>> I have a bunch of OpenStack Nova nodes, each with 11TB of local disk for
>> Cloud VMs.  This is all on RDO - RHEL 7 on OpenStack Kilo.  That local
>> storage is configured with a XFS filesystem.
>> If I specify 8TB on 'root filesystem size' in a flavor, it only seems to
>> be able to make a 2TB root filesystem on the guest.  No matter what
>> guest OS I use (I've tried CentOS 7.1, Ubuntu 15.10, others) it only
>> seems to be able to create a 2TB root filesystem.  I've also tried
>> making a 5GB root filesystem and specifying 8TB for ephemeral disk, but
>> the ephemeral disk that shows up on /tmp in the guest is only 2TB as
>> well.
>> Is there a 2TB KVM limit on VM size?  Max file size in ext4 and XFS is
>> well beyond 2TB, so I don't think that's it...  Maybe a limit in KVM or
>> libvirt?
>> The qemu xml file on the node does specify a 8TB disk....
>> Any insight most welcome!!
>> cheers,
>> erich

More information about the rdo-list mailing list