[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rdo-list] Rebuild a newer version of python-crypto ?



Hi,

I'm noticing an issue in the review.rdo gate.
We pip install zuul in the nodepool images (presumably for
zuul-cloner) which pulls in Paramiko which pulls pycrypto:
Collecting pycrypto!=2.4,<3.0,>=2.1 (from paramiko<2.0.0,>=1.8.0->zuul)

It looks like if we install crypto from both pip and packages, we're
bound to be running into issues like that:
====
Error: /Stage[main]/Glance/Package[openstack-glance]/ensure: change
from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y
install openstack-glance' returned 1: Error downloading packages:
  1:openstack-glance-13.0.0-0.20160817133141.bfe4d91.el7.centos.noarch:
[Errno 256] No more mirrors to try.
Error: Execution of '/bin/yum -d 0 -e 0 -y install
openstack-barbican-api' returned 1: Error unpacking rpm package
python-crypto-2.6.1-1.el7.x86_64
error: unpacking of archive failed on file
/usr/lib64/python2.7/site-packages/pycrypto-2.6.1-py2.7.egg-info:
cpio: rename failed - Is a directory
====

Reproduced here [1] on a fresh CentOS install with:
    1  yum -y install "@Development Tools" python-devel openssl-devel
libffi-devel libxml2-devel python-setuptools python-crypto
    2  yum -y remove python-crypto
    3  easy_install pip
    4  pip install pycrypto
    5  yum -y install python-crypto

I am unable to reproduce the issue on Fedora.
CentOS extras (and RDO) has python-crypto-2.6.1-1.el7.centos.x86_64
(2014) while Fedora has python-crypto-2.6.1-10.fc24 (2016).

Can we update the version we have in RDO ? Or is there some other root
cause I'm missing ?

[1]: http://pastebin.centos.org/52006/raw/

David Moreau Simard
Senior Software Engineer | Openstack RDO

dmsimard = [irc, github, twitter]


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]