[Rdo-list] RDO, packstack, Keypair creation is failing

Marius Cornea marius at remote-lab.net
Sun Jan 10 16:03:05 UTC 2016


You could try adding it via the CLI:

# generate the keypair; cloud.key is the private key; cloud.key.pub is
the public key
ssh-keygen -t rsa -f cloud.key -N ''

# load the keystone credentials
source keystonerc_admin

# import the public key
nova keypair-add --pub_key cloud.key.pub cloudkey


On Sat, Jan 9, 2016 at 7:46 PM, Thales <thaleslv at yahoo.com> wrote:
> Hello,
> I'm trying to learn OpenStack via RDO, so I downloaded packstack.  I went to
> this link to start on RDO
> https://www.rdoproject.org/install/quickstart/
> I set up a fixed IP in CentOS 7.    CentOS 7 is a guest OS.   I'm using
> Virtualbox as my virtual machine, and Windows 10 is my host OS.  I'm using a
> Bridged adpater for Virtual Box.
> I downloaded and installed RDO via packstack.
> I then went here:
> https://www.rdoproject.org/install/running-an-instance/
> I went there to learn how to run an instance, and on step three on that
> page, "Create or Import a Pair", I  received an error.    The error occurred
> when I tried to "create" the key.  It error was "Keypair data is invalid:
> failed to generate fingerprint (HTTP 400)".     I also tried to import a
> key, by generating one on the command line.  However, in both cases it
> failed.  I got some guidance from this video
> ,https://www.youtube.com/watch?v=GYTctLuPbOs, but that didn't do the trick
> for me, either.
>   I have been looking around for similar problems on the web, and I found a
> couple, but none of the solutions worked for me.  I recently disabled
> SELinux with the "setenforce 0" command, and that didn't fix the problem
> either.
>   Does anyone have any idea what his could be?   I'm really just learning
> now, so I'm sure it's got to be something rudimentary.
>   Thanks for any help!
>   ...John
> _______________________________________________
> Rdo-list mailing list
> Rdo-list at redhat.com
> https://www.redhat.com/mailman/listinfo/rdo-list
> To unsubscribe: rdo-list-unsubscribe at redhat.com

More information about the rdo-list mailing list