[Rdo-list] RDO, packstack, Keypair creation is failing

Thales thaleslv at yahoo.com
Tue Jan 12 19:49:48 UTC 2016

Hello Sasha,
I tried your command, and got the following error:
[john at localhost ~]$ nova keypair-add cloudkey > cloudkey.priv; chmod 600 cloudkey.priv
ERROR (CommandError): You must provide a username or user id via --os-username, --os-user-id, env[OS_USERNAME] or env[OS_USER_ID]


    On Monday, January 11, 2016 6:28 PM, Sasha Chuzhoy <sasha at redhat.com> wrote:

 Hi John,
Does this command work for you:
 nova keypair-add cloudkey >cloudkey.priv; chmod 600 cloudkey.priv

If it works (nova keypair-list), you could ssh to the instance launched with the key using:
ssh -i cloudkey.priv <user>@<IP>

Best regards,
Sasha Chuzhoy.

----- Original Message -----
> From: "Thales" <thaleslv at yahoo.com>
> To: "Marius Cornea" <marius at remote-lab.net>
> Cc: rdo-list at redhat.com
> Sent: Sunday, January 10, 2016 10:50:12 PM
> Subject: Re: [Rdo-list] RDO, packstack, Keypair creation is failing
> Thanks, Marius!
> I get the same error.
> "Error (BadRequest): Keypair data is invalid: failed to generate fingerprint
> (HTTP p 400) (Requested ID: ...)"
> I'm just staring out with OpenStack here, trying to get through my first
> tutorial, so I'm fumbling around.
> ...John

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listman.redhat.com/archives/rdo-list/attachments/20160112/0aa365f5/attachment.htm>

More information about the rdo-list mailing list