[Rdo-list] Slow network performance on Kilo?

Erich Weiler weiler at soe.ucsc.edu
Wed Jan 27 20:30:51 UTC 2016

Hi Y'all,

I've seen several folks on the net with this problem, but I'm still 
flailing a bit as to what is really going on.

We are running RHEL 7 with RDO OpenStack Kilo.

We are setting this environment up still, not quite done yet.  But in 
our testing, we are experiencing very slow network performance when 
downloading or uploading to and from VMs.  We get like 300Kb/s or so.

We are using Neutron, MTU 9000 everywhere.  I've tried disabling GSO, 
LRO, TSO, GRO on the neutron interfaces, as well as the VM server 
interfaces, still no improvement.  I've tried lowing the VM MTU to 1500, 
still no improvement.   It's really strange.  We do get connectivity, I 
can ssh to the instances, but the network performance is just really, 
really slow.  It appears the instances can talk to each other very 
quickly however.  They just get slow network to the internet (i.e. when 
packets go through the network node).

We are using VLAN tenant network isolation.

Can anyone point me in the right direction?  I've been beating my head 
against a wall and googling without avail for a week...

Many thanks,

More information about the rdo-list mailing list