[Rdo-list] Slow network performance on Kilo?

Dan Sneddon dsneddon at redhat.com
Fri Jan 29 22:16:48 UTC 2016

On 01/27/2016 12:30 PM, Erich Weiler wrote:
> Hi Y'all,
> I've seen several folks on the net with this problem, but I'm still
> flailing a bit as to what is really going on.
> We are running RHEL 7 with RDO OpenStack Kilo.
> We are setting this environment up still, not quite done yet.  But in
> our testing, we are experiencing very slow network performance when
> downloading or uploading to and from VMs.  We get like 300Kb/s or so.
> We are using Neutron, MTU 9000 everywhere.  I've tried disabling GSO,
> LRO, TSO, GRO on the neutron interfaces, as well as the VM server
> interfaces, still no improvement.  I've tried lowing the VM MTU to
> 1500, still no improvement.   It's really strange.  We do get
> connectivity, I can ssh to the instances, but the network performance
> is just really, really slow.  It appears the instances can talk to each
> other very quickly however.  They just get slow network to the internet
> (i.e. when packets go through the network node).
> We are using VLAN tenant network isolation.
> Can anyone point me in the right direction?  I've been beating my head
> against a wall and googling without avail for a week...
> Many thanks,
> erich
> _______________________________________________
> Rdo-list mailing list
> Rdo-list at redhat.com
> https://www.redhat.com/mailman/listinfo/rdo-list
> To unsubscribe: rdo-list-unsubscribe at redhat.com

To use jumbo frames with Neutron, you first need to make sure that all
layers have the same MTU: bridge, interface, VLAN, and bond (if

Check these settings on both Controllers and Computes:

In /etc/nova/nova.conf, edit or create this line:

In /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini:
 veth_mtu = 9000

That will increase the MTU on the virtual Ethernet adapter to. You can
get away with an MTU here that matches the wire in Neutron VLAN mode.
In VXLAN you'd want this value to be 50 bytes less than the MTU on the

You also want to check the DHCP options in the file
/etc/neutron/dnsmasq-neutron.conf on all controllers:

You can also try setting that last option to 1400, that will limit the
VM MTU, but if things speed up then you know you've got a bottleneck
somewhere (like a less-than 1500-byte MTU somewhere in the path of VLAN

Dan Sneddon         |  Principal OpenStack Engineer
dsneddon at redhat.com |  redhat.com/openstack
650.254.4025        |  dsneddon:irc   @dxs:twitter

More information about the rdo-list mailing list