[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] Overcloud Deployment failsm not br-int



Hi Gabriel,

Any reason you are trying to install such an old version? Kilo is no longer supported and the repository has been archived.

I'd recommend trying again with Liberty or perhaps Mitaka first.

 
Regards, 

Christopher Brown 
OpenStack Engineer 
OCF plc 

Tel: +44 (0)114 257 2200 
Web: www.ocf.co.uk 
Blog: blog.ocf.co.uk 
Twitter: @ocfplc 

OCF plc is a company registered in England and Wales. Registered number 4132533, VAT number GB 780 6803 14. Registered office address: OCF plc, 5 Rotunda Business Centre, Thorncliffe Park, Chapeltown, Sheffield, S35 2PG. 

This message is private and confidential. If you have received this message in error, please notify us and remove it from your system.


-------- Original message --------
From: Gabriel Peral <gbrlperal gmail com>
Date: 31/07/2016 10:16 a.m. (GMT+00:00)
To: rdo-list redhat com
Subject: [rdo-list] Overcloud Deployment failsm not br-int

Hi everyone!

I've been trying to deploy OpenStack using TripleO for 2 weeks and I am get stucked in the same step.

But let's see first my environment, 3 baremetal nodes, one will be a compute node, the other two will be compute nodes. In each pyhiscal node I have two pyhiscal NICs, one for the PXE+DHCP provisioning, and the other pyhsical NIC connected to a pyhiscal switch which has the rest of the vlans for the deployment (api, storage, tenant, exeternal, etc). I am deploying OpeStack Kilo version.
The first step of the installation was good, the undercloud and the introspection was done in the right way, but the problem cames when I try to deploy the overcloud, I set up the network-environment.yaml template in order to set the vlans to the networks, and the compute.yaml and controller.yaml templates to set the right NICs to the right networks. And then I launch the deploy command like this (vlan mode) :

$ openstack overcloud deploy --templates ~/templates/my-overcloud/ -e ~/templates/network-environment.yaml -e ~/templates/storage-environment.yaml -e ~/templates/my-overcloud/environments/network-isolation.yaml --control-scale 1 --compute-scale 2 --control-flavor control --compute-flavor compute --ntp-server 10.20.10.3 --neutron-network-type vlan --neutron-disable-tunneling --neutron-bridge-mappings datacentre:br-ex --neutron-network-vlan-ranges datacentre:30:100 --timeout 60 --verbose --log-file overcloud_vlan.log

And all seems go well untill it fails due to timeout, the 

heat resource-list --nested-depth 5 overcloud | grep FAILED

Show that something is wrong in the NetworkDeploy, and when I log into the controller node, if I type sudo ovs-vsctl list-br it only shows me the br-ex bridge, so it wasn't able to create the br-int, and I think that's the reason because the deployment has been failed, when I've tryied to deploy more i log into the controller node, and check the sudo tail -f  /var/log/messages and this is the only message that appears:


Jul 31 04:59:53 overcloud-controller-0 os-collect-config: 2016-07-31 04:59:53.337 4606 WARNING os-collect-config [-] Source [ec2] Unavailable.
Jul 31 04:59:53 overcloud-controller-0 os-collect-config: 2016-07-31 04:59:53.624 4606 WARNING os-collect-config [-] Source [request] Unavailable.
Jul 31 04:59:53 overcloud-controller-0 os-collect-config: 2016-07-31 04:59:53.625 4606 WARNING os_collect_config.local [-] /var/lib/os-collect-config/local-data not found. Skipping
Jul 31 04:59:53 overcloud-controller-0 os-collect-config: 2016-07-31 04:59:53.625 4606 WARNING os_collect_config.local [-] No local metadata found (['/var/lib/os-collect-config/local-data'])
Jul 31 05:00:26 overcloud-controller-0 os-collect-config: 2016-07-31 05:00:26.615 4606 WARNING os_collect_config.ec2 [-] ('Connection aborted.', error(113, 'No route to host'))
Jul 31 05:00:26 overcloud-controller-0 os-collect-config: 2016-07-31 05:00:26.615 4606 WARNING os-collect-config [-] Source [ec2] Unavailable.
Jul 31 05:00:26 overcloud-controller-0 os-collect-config: 2016-07-31 05:00:26.833 4606 WARNING os-collect-config [-] Source [request] Unavailable.
Jul 31 05:00:26 overcloud-controller-0 os-collect-config: 2016-07-31 05:00:26.833 4606 WARNING os_collect_config.local [-] /var/lib/os-collect-config/local-data not found. Skipping
Jul 31 05:00:26 overcloud-controller-0 os-collect-config: 2016-07-31 05:00:26.834 4606 WARNING os_collect_config.local [-] No local metadata found (['/var/lib/os-collect-config/local-data'])

So something is wrong with the network, but I don't know what because I can ping the external network and gateway from the controller node.

If someone knows what could be I would be so glad, because I've been trying to deploy and all the times it fails

Kind regards,

Gabriel

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]