[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] Baremetal Tripleo stable version?



Hi Christopher,

thank you, I'll test it out.

According with my interpretation from documentation, mitaka version is made from nightly builds, as the "stable" version is from liberty.

Maybe someone from rdo can clarify this.

Anyway, both seem broken right now, like you I test this in baremetal for deploying in production, not in virtual environments.

Regards


On Fri, Jun 3, 2016 at 9:36 AM, Christopher Brown <cbrown2 ocf co uk> wrote:
Hi Pedro,

TL;DR Try the links below and if fails try Liberty.

We've got Mitaka working after some of the frustrations you are
experiencing. The image that gets built doesn't work. There was some
discussion as to whether a hiera update broke this - it was reverted
but the image still seems broken.

Try using these:

http://buildlogs.centos.org/centos/7/cloud/x86_64/tripleo_images/mitaka
/cbs/


We used packages from:

https://repos.fedorapeople.org/repos/openstack/openstack-mitaka/

but the introspection is broken due to a race condition that hasn't
been patched in this stable repo yet (I believe).

Not given up yet but yes, Liberty tripleo worked fine for us.

There seems to be a large amount of development work going into
tripleo-quickstart which doesn't really work for production use and I'm
not sure if the developers have access to lots of baremetal for
testing. As a result I think actual production RDO doesn't get huge
amounts of testing - I'm talking baremetal HA controllers with network
isolation over bonded connections etc.

We have abandoned the tripleo docs and use the Red Hat docs as a
reference.

I have no idea how to actually run Mitaka stable. When I follow the
tripleo docs and use the "stable" delorean repo (still not sure what
that actually is) I end up with packages like:

python-neutron-8.1.2-0.20160602095303.449bcc6.el7.centos.noarch

which seems to indicate it is a nightly snapshot from git. Obviously
I'd rather not run that in production.

Its all a bit of a mess. I did try to make a start on cleaning up the
RDO docs but to be honest it meant having to learn yet another type of
documentation syntax so have reverted to internal documentation.

Cheers

On Fri, 2016-06-03 at 08:17 +0100, Pedro Sousa wrote:
> The problem is that I cant install none, both fail :-(. I've managed
> to install mitaka at some point but then something was updated that
> broke the installation and I get that rabbitmq problem. Its
> frustating.
> Guess I'll have to get back to packstack, its the only method that
> actually works fine so far.
> Christopher did you manage to install liberty stable? Had to update
> anything on overcloud image?
> Thanks
> Em 03/06/2016 06:34, "Christopher Brown" <cbrown2 ocf co uk>
> escreveu:
> > I'm glad you said it.
> >
> > I'm having exactly the same problem. I've had to customize an image
> > due to missing python-hardware-detect and introspection is very hit
> > and miss.
> >
> > Currently testing delorean packages but may have to consider
> > reverting to Liberty.
> >
> > Documentation is not clear and still references Liberty. I think
> > some mitaka stabilisation work would be gratefully received.
> >
> >
> > Regards,
> >
> > Christopher Brown
> >
> >
> > -------- Original message --------
> > From: Pedro Sousa <pgsousa gmail com
> > Date: 03/06/2016 04:11 (GMT+00:00)
> > To: rdo-list <rdo-list redhat com
> > Subject: [rdo-list] Baremetal Tripleo stable version?
> >
> > Hi all,
> >
> > been doing some tests on baremetal hosts, but I'm kind of stuck
> > here, it's getting to start to be frustrating.
> >
> > I've followed the documentation from http://docs.openstack.org/deve
> > loper/tripleo-docs/
> >
> > First I've tried the stable version from liberty and got stuck in a
> > python-config-oslo outdated package bug.
> >
> > Then I've tried mitaka and I got stuck in this error:
> >
> > "Could not retrieve fact='rabbitmq_nodename',
> > resolution='<anonymous>': undefined method `[]' for nil:NilClass
> > Could not retrieve fact='rabbitmq_nodename',
> > resolution='<anonymous>': undefined method `[]' for nil:NilClass"
> >
> > My question is if there's a stable version that can be installed on
> > overcloud baremetal hosts that we can rely on?
> >
> > Thanks
> >
--
Regards,

Christopher Brown
OpenStack Engineer
OCF plc

Tel: +44 (0)114 257 2200
Web: www.ocf.co.uk
Blog: blog.ocf.co.uk
Twitter: @ocfplc

Please note, any emails relating to an OCF Support request must always
be sent to support ocf co uk for a ticket number to be generated or
existing support ticket to be updated. Should this not be done then OCF

cannot be held responsible for requests not dealt with in a timely
manner.

OCF plc is a company registered in England and Wales. Registered number

4132533, VAT number GB 780 6803 14. Registered office address: OCF plc,

5 Rotunda Business Centre, Thorncliffe Park, Chapeltown, Sheffield S35
2PG.

If you have received this message in error, please notify us
immediately and remove it from your system.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]