[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] Baremetal Tripleo stable version?



I did not had issues with introspection, built images both liberty and mitaka from delorean repos. 

The problem is applying the heat templates when the overcloud is up, puppet issues, etc.



On Fri, Jun 3, 2016 at 3:09 PM, Ignacio Bravo <ibravo ltgfederal com> wrote:
I had issues with the introspection of nodes, due to a race condition that was fixed by dtantsur. The issue was that the official images did not include the patch, and thus were not usable by me. I tried creating the images myself and those too were failing.

I got out of trying the nightly builds, as I was looking for a more long term solution, so I was using the official production repos that were on centos.org (I believe they were http://mirror.centos.org/centos/7/cloud/x86_64/openstack-mitaka/ but can’t recall right now)
The patch was not included on those packages when I was trying this out, that was just about the Austin summit.


IB

 
__
Ignacio Bravo
LTG Federal, Inc


On Jun 3, 2016, at 9:49 AM, Pedro Sousa <pgsousa gmail com> wrote:

Hi Ignacio,

what versions have you tried to install and what problems have you found?

Until now I've only managed to install once 1 controller + 1 compute using mitaka nightly build. Everything else has failed. Testing now without delorean repos on liberty.

Regards


On Fri, Jun 3, 2016 at 2:30 PM, Ignacio Bravo <ibravo ltgfederal com> wrote:
Pedro / Christopher,

Just wanted to share with you that I also had plenty of issues deploying on bare metal HA servers, and have paused the deployment using TripleO until better winds start to flow here. I was able to deploy the QuickStart, but on bare metal the history was different. Couldn't even deploy a two server configuration.

I was thinking that it would be good to have the developers have access to one of our environments and go through a full install with us to better see where things fail. We can do this handholding deployment once every week/month based on developers time availability. That way we can get a working install, and we can troubleshoot real life environment problems.


IB

On Jun 3, 2016, at 6:15 AM, Pedro Sousa <pgsousa gmail com> wrote:

Yes. I've used this, but I'll try again as there's seems to be new updates.



Stable Branch

 

Skip all repos mentioned above, other than epel-release which is still required.

Enable latest RDO Stable Delorean repository for all packages

sudo curl -o /etc/yum.repos.d/delorean-liberty.repo https://trunk.rdoproject.org/centos7-liberty/current/delorean.repo

Enable the Delorean Deps repository

sudo curl -o /etc/yum.repos.d/delorean-deps-liberty.repo http://trunk.rdoproject.org/centos7-liberty/delorean-deps.repo

On Fri, Jun 3, 2016 at 11:10 AM, Christopher Brown <cbrown2 ocf co uk> wrote:
No, Liberty deployed ok for us.

It suggests to me a package mismatch. Have you completely rebuilt the
undercloud and then the images using Liberty?

On Fri, 2016-06-03 at 11:04 +0100, Pedro Sousa wrote:
> AttributeError: 'module' object has no attribute 'PortOpt'
--
Regards,

Christopher Brown
OpenStack Engineer
OCF plc

Tel: +44 (0)114 257 2200
Web: www.ocf.co.uk
Blog: blog.ocf.co.uk
Twitter: @ocfplc

Please note, any emails relating to an OCF Support request must always
be sent to support ocf co uk for a ticket number to be generated or
existing support ticket to be updated. Should this not be done then OCF

cannot be held responsible for requests not dealt with in a timely
manner.

OCF plc is a company registered in England and Wales. Registered number

4132533, VAT number GB 780 6803 14. Registered office address: OCF plc,

5 Rotunda Business Centre, Thorncliffe Park, Chapeltown, Sheffield S35
2PG.

If you have received this message in error, please notify us
immediately and remove it from your system.

_______________________________________________
rdo-list mailing list
rdo-list redhat com
https://www.redhat.com/mailman/listinfo/rdo-list

To unsubscribe: rdo-list-unsubscribe redhat com




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]