[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rdo-list] mitaka installation



trying to install openstack mitaka I met problems with the procedure
described on https://www.rdoproject.org/install/quickstart/

final messages from   packstack --allinone are below

=========================================
193.124.84.22_prescript.pp:                          [ DONE ]
Applying 193.124.84.22_amqp.pp
Applying 193.124.84.22_mariadb.pp
193.124.84.22_amqp.pp:                               [ DONE ]
193.124.84.22_mariadb.pp:                            [ DONE ]
Applying 193.124.84.22_apache.pp
193.124.84.22_apache.pp:                             [ DONE ]
Applying 193.124.84.22_keystone.pp
Applying 193.124.84.22_glance.pp
Applying 193.124.84.22_cinder.pp
193.124.84.22_keystone.pp:                        [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 193.124.84.22_keystone.pp
Error: Could not prefetch keystone_role provider 'openstack': Could
not authenticate
You will find full trace in log
/var/tmp/packstack/20160616-133447-C9hfh9/manifests/193.124.84.22_keystone.pp.log
Please check log file
/var/tmp/packstack/20160616-133447-C9hfh9/openstack-setup.log for more
information
Additional information:
 * Time synchronization installation was skipped. Please note that
unsynchronized time on server instances might be problem for some
OpenStack components.
 * File /root/keystonerc_admin has been created on OpenStack client
host 193.124.84.22. To use the command line tools you need to source
the file.
 * To access the OpenStack Dashboard browse to http://193.124.84.22/dashboard .
Please, find your login credentials stored in the keystonerc_admin in
your home directory.
 * To use Nagios, browse to http://193.124.84.22/nagios username:
nagiosadmin, password: f9d91344c4bb4f21
===============

the file keystone_role/openstack.rb is from package
openstack-puppet-modules-8.0.4-1.el7.noarch  (from repo openstack-mitaka)

I repeated several times with full reinstallition (yum erase
[everything from repo openstack-mitaka], deletion all conf
directories, yum install)



Additional info

cat /etc/os-release
NAME="Scientific Linux"
VERSION="7.2 (Nitrogen)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="7.2"
PRETTY_NAME="Scientific Linux 7.2 (Nitrogen)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:scientificlinux:scientificlinux:7.2:GA"
HOME_URL="http://www.scientificlinux.org//";
BUG_REPORT_URL="mailto:scientific-linux-devel listserv fnal gov"

REDHAT_BUGZILLA_PRODUCT="Scientific Linux 7"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Scientific Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="7.2"

Somebody has ideas how to fix it ?

Many thanks in advance.

-- 
Andrey Y Shevel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]