[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] Adding backwards compatible tripleo-heat-templates packaging



On Fri, Sep 2, 2016 at 6:04 PM, Alan Pevec <apevec redhat com> wrote:
>> * A single srpm if at all possible
>
> Why is that a requirement? Usually in rpm world you create separate
> parallel installable compat package by adding version to the package
> name e.g. we had python-webob1.2 in the past.
> THT mitaka is 2.x so what about creating a new package
> openstack-tripleo-heat-templates2 ?

We could do that and it's ok, really.  It just means a new package
process for every release of OpenStack.  There is no real clean
mapping historically of THT version to OpenStack version.  How does
someone know that tht2 is mitaka?  When we reach ocata and have to
have a BC package, it's tht5 which is newton.  (We could simply name
it openstack-tripleo-heat-templates-mitaka).

The proposal currently means that we have to change 1 spec file value
per release rather than go through a totally new package each release.

Mike


>
> Alan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]