[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] [TripleO] ControllerLoadBalancerDeployment_Step1 resource failed



On Wed, Sep 7, 2016 at 8:20 AM, Samuel Monderer
<smonderer vasonanetworks com> wrote:
> Hi,
>
> I have one controller and one compute node both with 3 NICs: IPMI,net1 and
> net2
> I've based my overcloud configuration on the bond with vlans but I removed
> the bond and just used a single NIC instead.
> For the moment I don't need storage as my setup is a NFV cloud, so I removed
> the storage network and storage-management network.

The storage network is also used for the Glance API so by default it
is used even though you're not deploying any storage nodes. I
recommend section 6.2.4 of these docs which explains how to choose
which networks to deploy:
https://access.redhat.com/documentation/en/red-hat-openstack-platform/9/paged/director-installation-and-usage/chapter-6-configuring-advanced-customizations-for-the-overcloud

> Network configuration per node
>
> controller:
>
> IPMI
> NIC1:
>
> Provioning Network
>
> NIC2
>
> Internal Network
> Tenant Network
> Management Network
> External Network
>
> compute
>
> IPMI
> NIC1:
>
> Provioning Network
>
> NIC2
>
> Internal Network
> Tenant Network
> Management Network

Checking the attached network templates I see that you're setting the
vlan interfaces as members of the physical interface. I'm not sure
that works. I usually create a bridge and make the interface and the
vlans members of it, e.g:
http://paste.openstack.org/show/567426/

> By the way what is the management netwrok for? Is it for accesssing the
> nodes without going through the director?

The management network is typically used for providing external
connectivity for non controller nodes.

> I ran the deployment but the following resources failed
> overcloud-ControllerNodesPostDeployment-4lpz4z4msgzz-ControllerLoadBalancerDeployment_Step1-nc4sfpp34a57
> overcloud-ControllerNodesPostDeployment-4lpz4z4msgzz
> overcloud-ComputeNodesPostDeployment-ougcodme2eo2
>
> When I checked the  os-collect-config log on the controller  I found that It
> wasn't able to reach the mysql server (attached is the log file)
>
> Any Idea what could be the issue?

First thing I'd check is if the network setting got applied by running
'ip a; ip r'

> Attached are also the configuration files
>
> Regards,
> Samuel
>
> _______________________________________________
> rdo-list mailing list
> rdo-list redhat com
> https://www.redhat.com/mailman/listinfo/rdo-list
>
> To unsubscribe: rdo-list-unsubscribe redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]