[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] RabbitMQ version in RDO



So I think what's the underlying question here is how do we define
when to update non-OpenStack components that RDO carries in it's
repositories.

I think with OpenStack components it's easier, there's branches and we
build/test them throughout the lifecycle.
Once we have the proper testing in place, we can update those more frequently.

This isn't limited to RabbitMQ, there's other things like
mariadb/galera, puppet and so on.
Should we try to always have the most up-to-date version (given we are
confident enough in our testing?) ?
Should we only update on a need/request basis ? Only when there's a
known critical bug or CVE ?

We should agree on something and document that somewhere.

David Moreau Simard
Senior Software Engineer | Openstack RDO

dmsimard = [irc, github, twitter]


On Tue, Sep 20, 2016 at 10:12 AM, Alan Pevec <apevec redhat com> wrote:
>> In this case, I'm wondering if it is possible to get a newer version
>> of RabbitMQ in the Mitaka RDO repos, the reason behind this is that
>> there is a bug affecting us which results in RabbitMQ nodes crashing.
>> The details of the bug are here:
>>
>> https://github.com/rabbitmq/rabbitmq-management/issues/245
>>
>> This issue is resolved in 3.6.4, but 3.6.2 is what is included in the
>> RDO repos.
>
> There is 3.6.5 update in the pending repo:
> http://cbs.centos.org/repos/cloud7-openstack-common-pending/x86_64/os/Packages/
>
> Please test it and report here.
>
> Cheers,
> Alan
>
> _______________________________________________
> rdo-list mailing list
> rdo-list redhat com
> https://www.redhat.com/mailman/listinfo/rdo-list
>
> To unsubscribe: rdo-list-unsubscribe redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]