[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [rdo-list] RPM (minimum version) dependencies (pike)



On Fri, Sep 1, 2017 at 1:10 PM, Haïkel <hguemar fedoraproject org> wrote:
> 2017-09-01 21:14 GMT+02:00 iain MacDonnell <rdo-list dseven org>:
>> Experimenting with upgrading RDO Ocata to Pike in my lab, and have run
>> into a couple of RPM minimum version dependency issues.
>>
>
> Thanks for your quick feedback, it's much appreciated.
>
>> 1) neutron-server and agents fail to start, with:
>>
>> # neutron-server
>> Guru meditation now registers SIGUSR1 and SIGUSR2 by default for
>> backward compatibility. SIGUSR1 will no longer be registered in a
>> future release, so please use SIGUSR2 to generate reports.
>> Traceback (most recent call last):
>>   File "/usr/bin/neutron-server", line 6, in <module>
>>     from neutron.cmd.eventlet.server import main
>>   File "/usr/lib/python2.7/site-packages/neutron/cmd/eventlet/__init__.py",
>> line 15, in <module>
>>     eventlet_utils.monkey_patch()
>>   File "/usr/lib/python2.7/site-packages/neutron/common/eventlet_utils.py",
>> line 25, in monkey_patch
>>     p_c_e = importutils.import_module('pyroute2.config.asyncio')
>>   File "/usr/lib/python2.7/site-packages/oslo_utils/importutils.py",
>> line 73, in import_module
>>     __import__(import_str)
>> ImportError: No module named asyncio
>>
>
> Ok, I need to look into that. asyncio is a py3 thing only, it
> shouldn't appear at runtime.
>
>>
>> I have:
>>
>> # rpm -q python2-pyroute2
>> python2-pyroute2-0.4.8-1.el7.noarch
>>
>> which meets the dependency:
>>
>> # rpm -qR python-neutron-11.0.0-1.el7.noarch | grep pyroute2
>> python-pyroute2 >= 0.4.3
>>
>>
>> but the latest version (in the openstack-pike repo) is 0.4.19 (and
>> neutron works after explicitly updating to that). Seems that the
>> "Requires" in python-neutron needs to be bumped up.
>>
>
> Ok, if you have a RDO gerrit account, you may submit the change directly
>
>>
>> 2) Horizon fails to start due to https://bugs.launchpad.net/horizon/+bug/1701765
>>
>> Per comments in that bug, python-XStatic-Bootstrap-SCSS >= 3.3.7.1 is
>> required., but we have:
>>
>> # rpm -qR openstack-dashboard-12.0.0-1.el7.noarch | grep SCSS
>> python-XStatic-Bootstrap-SCSS
>>
>>
>> So it seems that the minimum version needs to be added to that "Requires".
>>
>> I can file a bug (or two) on this if it'd be helpful... ?
>>
>>     ~iain
>>
>
> Yes, assign me => hguemar AT redhat DOT org
> You can also submit changes directly where you see fit :)

I don't think I have privileges to do either of those things ;) but
I've reported the two issues as bugs 1487766 and 1487767

Thanks!

    ~iain


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]