[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[rdo-list] Upgrading from Newton to Ocata



Hello RDO Team,

I'm still fairly new to OpenStack so this may be because I didn't read the documentation closely enough before the upgrade, but I ran into an issue that I was hoping to get some clarification on.

I used this page to perform the upgrade [1].

Everything went smoothly until setting up cells for the first time.  I had not done this in Newton.

I got to step 14: "List registered cells to get their UUIDs:" which worked great.  I had cell0 and cell1 created from previous steps, everything seemed to be in place.

The next step says: "Pass the UUIDs to the map_instances command to map instances to cells:" with the following command example:
"# su -s /bin/sh -c "nova-manage cell_v2 map_instances --cell_uuid <cell UUID>" nova"

I took this to mean run that command for both cell0 and cell1.  So I did.  That mapped all my instances to cell0.

I then started seeing errors like this in the logs:
ERROR nova.api.openstack.extensions DriverLoadFailure: Failed to load transport driver "none": No 'oslo.messaging.drivers' driver found, looking for u'none'

After much searching, I found the transport_url for cell0 in the database was set to "none:///" which is what was causing the error.

I was able to create new instances, but not run any commands at all on current instances and all new instances were brought up in cell1.

So I moved all current instances to cell1 by manually updating the database and all the errors went away and everything is running correctly.

So my question is, did I do something else wrong that would cause this not to work properly or should those instructions be clarified a bit to say map instances to cell1, not cell0? 

In my searching I did find other guides that did all these same things, but specifically said map instances to cell1.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]