[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[RHBA-2001:048-03] New Update Agent with many fixes and enhanced functionality available

                   Red Hat, Inc. Red Hat Bug Fix Advisory

Synopsis:          New Update Agent with many fixes and enhanced functionality available
Advisory ID:       RHBA-2001:048-03
Issue date:        2001-04-12
Updated on:        2001-04-13
Product:           Red Hat Linux
Keywords:          up2date rpm rpm-python kernel upgrade dependency proxy
Cross references:  
Obsoletes:         RHBA-2000:138

1. Topic:

A new version of Update Agent is available which has more features and
fixes many bugs present in the existing Agent.  Dependency resolution is
more aggressive, command line operation is enhanced, and errata information
is available.

2. Relevant releases/architectures:

Red Hat Linux 6.2 - alpha, i386, noarch, sparc

Red Hat Linux 7.0 - alpha, i386

3. Problem description:

This release of Update Agent fixes several problems and numerous crashes
present in the last release, 2.1.7.  It also adds the ability to view
errata information on available packages, giving you more detailed insight
into why a particular package is available.  Command line functionality has
been greatly enhanced.  All known critical bugs have been addressed.

In addition to Update Agent, a new version of the RHN registration program
is being bundled, which fixes some problems with registering old older
processors like Intel 486s.

Both Update Agent and the RHN registration program now support proxies,
with or without authentication.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those

RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directly *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:


This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/bugzilla for more info):

18780 - up2date/rhn proxy
32221 - rhn_register fails with large swap space
32500 - rhn_register dies on old i386 systems during /proc cpuinfo call
35440 - rhn_register crashed in a RH6.2
15647 - up2date should explain reason for update
18994 - up2date hangs durring 'Removing packages ...'
18847 - UI should not block while downloading updates
19668 - up2date chokes on unmet dependencies
19669 - up2date shouldn't always quit when done
22984 - up2date install fails if multiple versions of updateable RPMs already installed
23215 - in rhn-config the proxy url format is bad
23240 - Update Agent fails with authenticated proxies
26214 - up2date fails on headless RH7 w/o x
23225 - Up2date exits after finding unsatisfied RPM dependency
23501 - If minutes >= 60, then displays 01:60:00, say
23971 - up2date -u gives nonsensical RPM error about dependencies
28921 - No up2date-config avail w/o gnome
32301 - up2date fails with undefined symbol: fdio
35154 - need to preserve permissions across lilo.conf copies

6. RPMs required:

Red Hat Linux 6.2:






Red Hat Linux 7.0:




7. Verification:

MD5 sum                           Package Name
bd0f93225dee3e0abe158dc1e94628f3 6.2/en/os/SRPMS/python-xmlrpc-1.4-0.6.x.src.rpm
98480ddbd4c9ba07086ea2c6505e6aa6 6.2/en/os/SRPMS/rhn_register-1.3.2-0.6.x.src.rpm
4608a2bc20033106d0b1ee7d1c4d3e5a 6.2/en/os/SRPMS/up2date-2.5.3-0.6.x.src.rpm
8fd575f6bdd624a74006144899b59632 6.2/en/os/alpha/python-xmlrpc-1.4-0.6.x.alpha.rpm
53dc69a4c155e9e7080080585a029791 6.2/en/os/alpha/up2date-2.5.3-0.6.x.alpha.rpm
7811c874d387993c81932d2a01f98406 6.2/en/os/alpha/up2date-gnome-2.5.3-0.6.x.alpha.rpm
de2d03f96758750334cf38c4f25f5d47 6.2/en/os/i386/python-xmlrpc-1.4-0.6.x.i386.rpm
07da9b3f37941a6bc0d64ff6f5e01b86 6.2/en/os/i386/up2date-2.5.3-0.6.x.i386.rpm
344d12a114e68f5764546cbe8daa6c8c 6.2/en/os/i386/up2date-gnome-2.5.3-0.6.x.i386.rpm
85b42d5a7e5260f14691cf8c063b4eb8 6.2/en/os/noarch/rhn_register-1.3.2-0.6.x.noarch.rpm
8f67daca63c64d648f33b8c8516b5036 6.2/en/os/noarch/rhn_register-gnome-1.3.2-0.6.x.noarch.rpm
468651817d6baa15101c9e29c75aeec9 6.2/en/os/sparc/python-xmlrpc-1.4-0.6.x.sparc.rpm
fbc9a09b9fd297dcefda7709096ebccf 6.2/en/os/sparc/up2date-2.5.3-0.6.x.sparc.rpm
46a1241d09c6096524988403d4f0d5a4 6.2/en/os/sparc/up2date-gnome-2.5.3-0.6.x.sparc.rpm
2e6dba30c75cc8a587eca73c11f98eca 7.0/en/os/SRPMS/python-xmlrpc-1.4-1.src.rpm
ee9f5ec9f845d5a9c2dc1fe125cc58f6 7.0/en/os/SRPMS/up2date-2.5.3-1.src.rpm
160a5b762fae919b93bd4586425b1f75 7.0/en/os/alpha/python-xmlrpc-1.4-1.alpha.rpm
566bc16085aa97b852150a93df3fc7b9 7.0/en/os/alpha/up2date-2.5.3-1.alpha.rpm
8946205b828d0279a4f29eca627daa33 7.0/en/os/alpha/up2date-gnome-2.5.3-1.alpha.rpm
06491152cc2f4d4acf895b851ca8b2f5 7.0/en/os/i386/python-xmlrpc-1.4-1.i386.rpm
67334f153230b06cd3669b0cccbc7cd9 7.0/en/os/i386/up2date-2.5.3-1.i386.rpm
2ab64f69c4c031d39ede67aa47a74533 7.0/en/os/i386/up2date-gnome-2.5.3-1.i386.rpm

These packages are GPG signed by Red Hat, Inc. for security.  Our key
is available at:

You can verify each package with the following command:
    rpm --checksig  <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    rpm --checksig --nogpg <filename>

8. References:

Copyright(c) 2000, 2001 Red Hat, Inc.

Redhat-watch-list mailing list
To unsubscribe, visit: https://listman.redhat.com/mailman/listinfo/redhat-watch-list

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]