kernel panic during install - can't find root device

Chris Buxton cbuxton at
Thu Jun 30 01:33:09 UTC 2005

I got it to work once with "linux root=/dev/hdc", but then during  
installation, the kernel had a problem with /dev/sda. And it hasn't  
worked again since.

If I specify the root device, except for that one time, it suggests I  
pass another option, "init=". What value should I assign to "init"?

I'm using an nForce3-based motherboard. I've tried messing with BIOS  
settings (loading alternately "failsafe" and "optimal" defaults).

Any hints for me?

Thanks in advance,
Chris Buxton

On Jun 29, 2005, at 6:00 PM, Chris Buxton wrote:

> I'm trying to install FC4 for x86-64. Details:
> - two AMD Opteron 244's
> - 2GB of RAM
> - booting from DVD (/dev/hdc) - I verified the sha1 hash
> - hard drive is on the second SATA controller, which under Debian  
> showed up as /dev/sda
> At the boot prompt, I've tried the default setting plus the  
> following commands:
> linux text
> linux root=/dev/hdc
> With the default setting, it claims it can't mount root device  
> <NULL>. If I set the root device to /dev/hdc, it complains that it  
> can't find something like "init" - it's hard to catch, since the  
> debugging trace information fills the screen shortly thereafter.
> Does anyone know what I should enter at the boot prompt?
> Thanks in advance,
> Chris Buxton
> _______________________________________________
> Redhat-install-list mailing list
> Redhat-install-list at
> To Unsubscribe Go To ABOVE URL or send a message to:
> redhat-install-list-request at
> Subject: unsubscribe

More information about the Redhat-install-list mailing list