[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RH Fedora network interfaces



----- Original Message ----- 
From: "Rodolfo J. Paiz" <rpaiz simpaticus com>
Sent: Thursday, February 19, 2004 6:29 AM
Subject: Re: RH Fedora network interfaces


> >I have full connectivity.  Do a full shutdown, boot up
> >again, everything works PERFECTLY.  Cool.  Do a warm-reboot - and we're
> >back to square one - Fedora comes up with the same exact message,
> >e100 device cannot> >find eth0 / eth1, and manually trying to bring
> >these interfaces up with ifup eth0 / ifup eth1 results in... nothing
> >(same error message as during bootup about missing e100 devices).
>
> Check with Intel, the mobo maker, or the server supplier? Possible hardware
> problem? Does this work with older RH OS's or any other OS's (i.e. is it
> Fedora-specific)?

Been there, done that.  It's a Supermicro server so they are the first people I
called.  They of course had "the latest" drivers available for it, which is what
I have tried on the last few attempts - with no changes.  Warm-booting still
doesn't work.  I've tried Intel, but only got the exact same version drivers
from them, which at least indicates that both Intel and Supermicro agree on the
current driver releases at least.

> I've had some fair experience building boxen and I've never seen this
> problem before, or anything like it... so I'm concerned that it might
> actually be hardware-related (or PROM/BIOS-related).

I don't think so - RH 7.3 and below work perfectly fine on this system.  It used
to run 7.3 for about a year on it without a single glitch.  I haven't tried RH8
but both RH9 and Fedora Core 1 have this same problem, which makes me believe
it's either driver or kernel related.  Like another guy here (Ed) suggested, I
also think it has to do with the PCI bus not being reset on warm reboot, or not
reset fully/properly, which is why it works on cold-boot every single time but
warm-boot acts as if the previous state has not been reset and the boot process
is not seeing these interfaces properly.

I am running out of ideas... I think I've tried just about everything at this
point.  One thing I have not tried is reloading it back with Rh 7.3 and see if I
can then upgrade to Fedora - maybe it will preserve some settings that will
reset the PCI bus on this thing?  So far all the problems I've had included
clean install or RH9 and Fedora, not upgrades.

Chris





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]