[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Re: USB to serial bug



Hi Ed,
Thanks for your reply.

I indeed tried setserial /dev/usb/ttyUSB0, but all I get is: Cannot get serial info: Invalid argument But a stty -a < /dev/usb/ttyUSB0 gives me the config of the device, which seems to be ok.

I actually get the same info with stty -a < /dev/usb/ttyUSB0 and stty -a < /dev/ttyS0, but these two devices behave differently.

Moreover, I can't think of any reason why I get a kernel panic when I reboot while a win hyperterm is trying to send data over the serial port.

As far as setup app for the device is concerned, it indeed came with a driver .. for windows :-(

Since I don't really have time to try and fix that right now, I'm more looking for advices regarding USB to serial that are known to work with my kernel.

By the way, there was a typo in my previous post: I'm obviously using kernels 2.4.20-x and not 20.4.20-x ;-)

Suggestions welcome.
Thanks in advance
Mathieu


Subject:
Re: USB to serial bug
From:
Edward Dekkers <edward tripled iinet net au>
Date:
Fri, 27 Feb 2004 08:50:55 +0800
To:
redhat-list redhat com


math wrote:

  Hello,

I've been trying to use a Bafo Technologies BF-810 USB to serial on my RedHat9 (20.4.20-8) box without success.
Here's a summary of what I've tried and some strange results I got

<SNIP>

I can't really help you here - as I (thankfully) haven't had to do this yet, but can the 'setserial' command work on the /dev/usb/ttyUSB0? If so, I would run it and check the parameters. If not, did the device come with a setup app to set DTR CTS handshaking and all that?

Sorry, that's all.

Regards,
Ed.







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]