[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pppd does not persist enough, gives up after 10 attempts



tom pollerman wrote:
On Sat, 28 Feb 2004 20:59:49 -0600
"Rodolfo J. Paiz" <rpaiz simpaticus com> wrote:


Hi!

Hopefully someone has a clue-by-four with which to hit me on this
one. I have an RHL-9 box (Shrike) with all updates and ppp-2.4.1-10
installed. This box is properly configured to dial out to my ISP on
an ISDN line (external modem via serial port), and works beautifully
in all ways but one: if pppd experiences 10 hang-ups, it exits and
does not restart.



 Rodolfo,

        Have you tried:

             maxfail 0

in your /etc/ppp/options file. I believe it defaults to 10 failed
connections - even if you have the 'persist' option specified.
   You may also want to check out:

                       http://www.tldp.org/HOWTO/PPP-HOWTO/x582.html

and have init 'respawn' pppd if it should stop responding
Best, Tom

Just adding my experiences with this problem. I've had this problem for a long time with no solution...

so I tried the 'maxfail 0' and the dialup/gateway box has been working perfectly for about two days now.

It used to drop the ppp0 interface about every twenty minutes or so [I didn't realize it was the number redials it was counting]. It appears to be a perfect fix.

I do have a question. Should I also use the 2nd fix suggested above by Tom.... ie
 setting pppd to automatically monitor and respawn itself
if the ppp0 interface goes down ?

Or would that be unnecessary overkill ?

Thanks guys for coming up with this fix... it made my day!!!!

John Kennedy







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]