[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Fwd: The modem chicken and egg question? Newbie Alert!]



On Fri, 2004-03-19 at 18:04, tom pollerman wrote:
> On Thu, 18 Mar 2004 22:35:26 -0000
> "J Simpson V21" <hubblesimpson members v21 co uk> wrote:
> 
> > 
> > >
> > > Hi,
> > > Is the com port availble?
> > > Try, as root:
> > > setserial /dev/ttyS3
> > >
> > > If should return something like:
> > > /dev/ttyS3, UART:  16550A, Port: 0x02e8, IRQ: 3
> > >
> > > If it is not enabled in hardware, it will show:
> > > /dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
> > >
> > > If needed, you can use setserial to change i/o & irq to match
> > > your hardware
> > > setings:
> > > setserial /dev/ttyS3 port 0x02e8 irq 3
> > > Have a look at "man seterial".
> > >
> > > Hope that helps.
> > > --
> > > Pete Nesbitt, rhce
> > >
> > 
> > Hi Pete,
> > 
> > Thanks for your response.
> > When I worked out how to get to root I tried setserial /dev/ttys3 it
> > said input/output error.  I tried setserial/dev/ttys3 it said no
> > such file or directory.
> > 
> > I found the man setserial and then tried setserial-g and setserial-a
> > and then I tried setserial -g and setserial -a
> > 
> > No of it gave me
> > >> If should return something like:
> > > /dev/ttyS3, UART:  16550A, Port: 0x02e8, IRQ: 3
> > >
> > > If it is not enabled in hardware, it will show:
> > > /dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3
> > 
> > The man file didn't make much sense apart from I didn't try anything
> > that said 'set' as there was a warning about locking up the
> > computer.
> > 
> > Any further help gratefully received.
> > 
> > I have Redhat 9 and a Motorola SM56 Speakerphone modem, on com 4.  I
> > just want to get online.
> > 
> 
>  /dev/ttys3 and /dev/ttyS3 are not the same... case is important (S
> and s.)
>  On my machine, which uses COM 2 (/dev/ttyS1):
> 
> [root linuxbox /root]# setserial /dev/ttys1
> /dev/ttys1: Input/output error
> 
> [root linuxbox /root]# setserial /dev/ttyS1
> /dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3
> 
>  The Motorola SM56 seems to be a 'softmodem', not a true hardware
> modem.
>  You can find the Linux drivers for RedHat 7.3, 8.0 and 9 at:
> 
>              http://www.motorola.com/softmodem/sm56_download.htm#linux
> 
> 
>                                            Tom
That could be it Linux does like the case to be correct.
Just as background according to the notes with the RH9 boxed set this
modem should work so lets hope trying again with the capital S will fix
it. If not it will have to be the driver which I think Janet may have
already downloaded.
We started this on the Yahoo Linuxathome list but moved to where the
experts are to get it sorted.
All we can do is wait and see.
Regards Roger




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]